upgrade less.js on bedrock sites

RESOLVED FIXED

Status

Infrastructure & Operations
WebOps: Other
RESOLVED FIXED
6 years ago
5 years ago

People

(Reporter: jlongster, Assigned: solarce)

Tracking

Details

(Reporter)

Description

6 years ago
I'm getting this error from dev every few min:

 [31mSyntax Error on line 343 [39m [31m in  [39m/data/bedrock-dev/src/www-dev.allizom.org-django/bedrock/media/css/firefox/technology.less
 [90m342  [39m
343  [33m [1m@ [22m-moz-keyframes glowheart { [39m
 [90m344   from { [39m [0m

Besides the fact that the it messed up the terminal text (weird), it seems that our minifier chokes on the technology.less file. Or maybe it's less?

It compiles fine locally, so we need to debug this on the dev server (presumably it will happen on the prod server too)
(Reporter)

Comment 1

6 years ago
Even weirder, the page seems to work fine:

http://www-dev.allizom.org/en-US/firefox/technology/

Updated

6 years ago
Summary: less compilation error on basket-dev → less compilation error on bedrock-dev
(Reporter)

Comment 2

6 years ago
I just tried using clean-css instead of YUI compressor and still couldn't reproduce it locally.
Possibly an outdated version of LESS CSS:
http://code.google.com/p/lesscss/issues/detail?id=11

Comment 4

6 years ago
Indeed, we are running 1.1.4 and that says it was fixed in 1.1.5.

oremj built our existing node-lessjs package for AMO... he says he can repackage the newer one. Not sure what kind of time expenditure this involves, and not sure how to do it myself (it seems to be part of a larger node.js package collection, maybe).
(Reporter)

Comment 5

6 years ago
For a quick fix, we can separate out the problematic css into a separate css file. It'd be great to fix this though. Should we track the progress in this bug or open a new one?

Comment 6

6 years ago
This bug is fine with me.
(Reporter)

Comment 7

6 years ago
Ok, tweaking the summary then.
Summary: less compilation error on bedrock-dev → upgrade less.js on bedrock sites
assigning to Brandon if he can find the time before Jeremy.  Also since this is a new version of a custom package, copying infrasec.
Assignee: server-ops → bburton
(Assignee)

Comment 9

6 years ago
I'm targeting to start on this in the morning on 3/13
Status: NEW → ASSIGNED
(Assignee)

Comment 10

6 years ago
Jason actually upgraded our package to 1.3.0 today, because AMO needed it. 

It has a new package name, but I can swap it out with puppet, let me know when is a good time to make the change and I'll get it done in modules/webapp/manifests/admin/bedrock.pp
(Assignee)

Comment 11

6 years ago
Just wanted to check on when would be a good time to switch out the packages so less can be upgraded
(Assignee)

Comment 12

6 years ago
Per IRC, good to do anytime.

I switched out the older package for the newer 1.3.0 package via Puppet.

script ran without error, let us know if you see any cron errors

[bburton@bedrockadm.private.phx1 cron.d]$ sudo -i bash -x /data/bedrock-dev/src/update-www-dev.allizom.org-django.sh
+ cd /data/bedrock-dev/src/www-dev.allizom.org-django/bedrock
+ git pull -q
+ git checkout dev -q
+ git submodule -q sync
+ git submodule -q update --init
+ pushd vendor
+ git submodule -q sync
+ git submodule -q update --init
+ popd
+ python manage.py compress_assets
+ touch wsgi/playdoh.wsgi
+ /data/bedrock-dev/deploy www-dev.allizom.org-django
Status: ASSIGNED → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → FIXED
Component: Server Operations: Web Operations → WebOps: Other
Product: mozilla.org → Infrastructure & Operations
You need to log in before you can comment on or make changes to this bug.