add puppet-managed "validation" step to slave startup

RESOLVED DUPLICATE of bug 712206

Status

Infrastructure & Operations
RelOps
RESOLVED DUPLICATE of bug 712206
6 years ago
5 years ago

People

(Reporter: dustin, Assigned: dustin)

Tracking

Details

This mechanism would validate that a slave meets expectations for things that cannot be automatically made right by puppet.  Screen resolutions were a big example of this, but I'm sure a search of the memory banks could turn up other places this would be useful.

To be clear, these would take the place of puppet resources that simply check something and fail or reboot if it is not the case -- such resources conflate puppet failures with host failures, and often cause the slave to continue hammering the puppet master for a problem that puppet will never be able to fix.

The general idea here would be for puppet to manage /etc/slave-validation.d, which is filled with scripts that are run *after* puppet and *before* runslave.  If any of them fail, the slave startup either bails out and awaits manual intervention, or reboots.
see also bug 712206. there are other things (not just validation) that we want to run after puppet and before runslave.
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 712206
Component: Server Operations: RelEng → RelOps
Product: mozilla.org → Infrastructure & Operations
You need to log in before you can comment on or make changes to this bug.