policy change request: require Mozilla-related content

RESOLVED WONTFIX

Status

Websites
planet.mozilla.org
RESOLVED WONTFIX
6 years ago
6 years ago

People

(Reporter: dietrich, Unassigned)

Tracking

Details

(Reporter)

Description

6 years ago
Planet is super high volume even with Mozilla-only posts. We should require at least some relation to the project for posts aggregated there.
This is in direct response to http://blog.gerv.net/2012/03/coalition-for-marriage-petition/

Some relevant comments from the post are as shown.

James said: Can you please keep your personal prejudices off Planet Mozilla?

Samuel Sidler said: Absolutely not. Planet is for all kinds of discussion from the Mozilla community. While I don’t agree wit Gerv’s stance here, I fully support his right as a community member to post his thoughts on Planet. Feel free to ignore posts you don’t like.

Chris Heilmann said: Sorry, I disagree. Planet Mozilla is an aggregator a lot of people – and press – look at. It is not the space of personal beliefs not related to the Mozilla mission. I don’t know _how_ we could fix that – maybe tag posts we don’t want on there with a “personal” tag or something like that, but I think we need to think of something. “Ignore posts” is never good advice. There is no lack of things to go through on Planet.

Pete said: Please leave your private things out of planet.mozilla

        Thank you

gerv said: Planet Mozilla, by policy, carries full feeds of all the blogs it carries. There’s plenty expressed there I don’t agree with, but I support this policy.

Pascal Chevrel said: Planet Mozilla shows the feed you provided it, not the full feed of the blog, otherwise you would see all my blog posts in French on planet :)

NJ said: That is incorrect. When I was posting to Planet, I used a tag and only Mozilla project specific posts fed to Planet.

        I was happy this was the case. My personal blog is exactly that – personal. I am involved in many projects and hold many opinions that had nothing to do with Mozilla and didn’t belong under the Mozilla banner. I was fine sharing my blog as a Mozilla asset while I was there, but very glad to keep my various worlds separate when appropriate.

Al Billings on March 6, 2012 at 6:00 PM said: Same here. Gerv and others don’t want to see my Buddhist posts on Planet so I’m unsure why we should be subjected to his desire to discriminate based on religion.

        (No, Gerv, don’t justify it. I grew up around Evangelical Christians and have two uncles who are ministers. I don’t need to hear the same arguments again.)

Danny Moules said: Ah… so Planet Mozilla is now a valid soapbox for this kind of thing? I have a feed specifically for poorly veiled bigotry – and I make a point of only reading when I’m in the correct frame of mind to do a thorough debunking of irrational logic.

       I do not expect it in my technical/community feeds.

       /unsub

Mike Beltzner said: Gerv is allowed his opinons, of course, and while I might not have chosen to syndicate this to Planet Mozilla, that feed is meant to be work and non work related issues of all Mozilla community members. Let’s not bash him for deciding to air his opinions, disagree as one – including myself – might.

       That aside, I am curious about the definition put forward here, Gerv. It explicitly states that it’s a “union for life,” which hints to the invalidity of marriages which can be torn asunder by the act of divorce. Does this definition thereby preclude the possibility for divorce, or at least, for subsequent remarriage?

Potch said: Regardless of whether I agree with you on this topic, this post doesn’t belong in a feed syndicated to Planet Mozilla.
A note to add that this was the policy at one point, when my blog was added circa 2005, and tor ran it.  I think it's a sane policy, since it allows me to keep only one blog, much of which I don't want published to pmo (i.e., it's ~60%+ non mozilla). +1
The Planet Mozilla Module Team has made a formal response to the cause of this bug. Please check out http://blog.mozilla.com/planet/2012/03/06/concerns-with-planet-content/ to read our reply, and do feel free to comment on the blog post.

As such, I'm resolving this particular bug as WONTFIX.
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → WONTFIX
  "Great cases like hard cases make bad law. For great cases are called
  great, not by reason of their importance... but because of some accident
  of immediate overwhelming interest which appeals to the feelings and
  distorts the judgment."  -- Oliver Wendell Holmes, Jr. [1]
                                   -- Michael Scott

Current policy, aiui, is pretty clear that blogs syndicated to PMO can essentially be about whatever community members syndicated there want. This has been established for quite some time. As PMO's volume has swelled in recent years, it's quite likely worth revisiting that at some point. Policy should be fresh and evolving, after all.

However, I pretty strongly disagree that now is the time to do so, per the OWH quote above. I think Gerv -- at _best_ -- exercised exceptionally poor judgement in choosing to post what he did. But I also think that a broad and reactionary policy change in response to a specific post is more likely than not to hurt in the future rather than help.

PMO volume is pretty overwhelming (I try to read it all). But I would posit that very little of the volume is due to non-Mozilla content, and very infrequently at that. If I was posting pictures of my cat to PMO [2], it would be but a minor irritation, 102psi firehose instead of a 100psi firehose. Prior to Gerv's post, I'd be surprised it if a "no non-Mozilla content" proposal got very far. I'd love to see some data that shows my impression is wrong, and that non-Mozilla content is a problem, but I don't think that's the case.

There's already work afoot to move "project" stuff to a separate planet/aggregator. I expect further changes will be needed to make PMO more useful and more relevant feed. Maybe part of that is limiting non-Mozilla content. But I think we should at least have a cooling-off period of a few weeks before doing so.

Now, if someone wants to propose a narrow policy change as a response to the immediate content of Gerv's post, I think that's an entirely different matter. Just as if someone was to make an inflammatory post regarding race, gender, religion, violence, etc... It's entirely fair to argue that a post is unacceptable in a community and to propose a specific remedy. But it feels like there is a gulf between the matter and hand and the proposed policy change.

[1] http://en.wikipedia.org/wiki/Hard_cases_make_bad_law
[2] http://blog.mozilla.com/dolske/2006/11/24/cat-food/ (still Mozilla relevant! :)
One question, and forgive my ignorance if this is easily discoverable: what is the expectation for feeds on planet?  Is it that it *must* be all, or that it *can* be all?  Many, many of us only post Mozillaish stuff, and I'd like to know if that's the expectation post policy revamp?
(In reply to David Humphrey (:humph) from comment #5)
> One question, and forgive my ignorance if this is easily discoverable: what
> is the expectation for feeds on planet?  Is it that it *must* be all, or
> that it *can* be all?  Many, many of us only post Mozillaish stuff, and I'd
> like to know if that's the expectation post policy revamp?

The policy hasn't changed. Since the module was founded in 2007, we've welcomed whatever feed-type people wish to provide us, whether it be a Mozilla-specific feed, an entire feed, or something in-between. It's up to the person requesting addition to Planet to decide what feed type he/she would like to use.
My point is that it was not always so (pre-2007), and those of us who were signed-up at that time may not know it is this way now--I know I didn't until this discussion started.  However, it sounds like *can* is the answer I was looking for here.

Comment 8

6 years ago
(In reply to David Humphrey (:humph) from comment #7)
> My point is that it was not always so (pre-2007), and those of us who were
> signed-up at that time may not know it is this way now--I know I didn't
> until this discussion started.  However, it sounds like *can* is the answer
> I was looking for here.

David, when we created the module, we tried to communicate the changes in the governance newsgroup and in the Planet Blog (which is syndicated to Planet, of course). We reached out to people who had filters placed on their blog to see about removing those and we tried to let people who had syndicated partial feeds that they could change that if they wanted to. I also presented the new policies and options at two or three Monday public All-hands meetings. See http://blog.mozilla.com/planet/2007/03/ and the .governance newsgroup for how that all went down.  

Obviously we didn't communicate it loudly enough if there are people on Planet who didn't hear about it. We'll try to do better in the future about communicating these kinds of changes and we're open to suggestions about what other channels we should be using.
You need to log in before you can comment on or make changes to this bug.