Please help verify locale detection

RESOLVED WORKSFORME

Status

www.mozilla.org
General
RESOLVED WORKSFORME
6 years ago
2 years ago

People

(Reporter: Laura Forrest, Unassigned)

Tracking

unspecified
x86
Mac OS X

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [kb=1830821] )

(Reporter)

Description

6 years ago
Currently our various Spanish speaking locales get a disproportionate amount of en-EN (Spanish in Spain) downloads. 

For example, the en-EN version is downloaded in Argentina twice as often as en-AR (Spanish for Argentina). 

Please verify the following:

1. What version of the homepage does a visitor from Argentina receive? (complete URL)

2. What version of the homepage does a visitor from Mexico receive? (complete URL)

3. What language of Firefox download does a visitor from Mexico receive?     

4. What language of Firefox download does a visitor from Argentina receive?     

Thanks!
Laura, do you want me  to  test using Firefox only as it depends on the browser and locale they are using when they hit the site.
(Reporter)

Comment 2

6 years ago
(In reply to raymond [:retornam] from comment #1)
> Laura, do you want me  to  test using Firefox only as it depends on the
> browser and locale they are using when they hit the site.

Good question. Since we want to replicate the main download use case, please test using any version of IE. 

For locale, please replicate the scenarios noted above. Meaning, in case #1, a visitor located in Argentina visiting, for example, www.firefox.com (naturally from their URL bar).
(Reporter)

Comment 3

6 years ago
Timing: Placing this in the 1.10 release for tracking purposes only, but since no dev work is needed at this time, it would be nice to have this information within the next 2 days by Thursday, 3/8 EOD.
We don't offer (and never did) a download depending on the country somebody lives in therefor testing this way is not going to work.

We offer downloads based on the language they currently use in their browser, if I live in Argentina but use IE in Portuguese, I will get offered a Portuguese download.

Also, the locale code for Spanish is also not en-EN but es-ES

Given that there hasn't been any change to the website related to locale management in at least a year (if not more), the cause is most likely external to the site. You should check for example that engagement is not promoting Firefox using donwload links with the es-ES or es (an alias to es-ES) locale code prefilled in South America.

good link for promotion in LATAM:
mozilla.com/firefox/

bad links for LATAM:
mozilla.com/es-ES/firefox
mozilla.com/es/firefox
read mozilla.org of course ;)
(Reporter)

Comment 6

6 years ago
(In reply to Pascal Chevrel:pascalc from comment #4)
> We don't offer (and never did) a download depending on the country somebody
> lives in therefor testing this way is not going to work.
> 
> We offer downloads based on the language they currently use in their
> browser, if I live in Argentina but use IE in Portuguese, I will get offered
> a Portuguese download.

Thanks for this clarity. Chofmann - is this the expected behavior? 
 
> Also, the locale code for Spanish is also not en-EN but es-ES
> Given that there hasn't been any change to the website related to locale
> management in at least a year (if not more), the cause is most likely
> external to the site. You should check for example that engagement is not
> promoting Firefox using donwload links with the es-ES or es (an alias to
> es-ES) locale code prefilled in South America.
> 
> good link for promotion in LATAM:
> mozilla.com/firefox/
> 
> bad links for LATAM:
> mozilla.com/es-ES/firefox
> mozilla.com/es/firefox
(Reporter)

Updated

6 years ago
Target Milestone: 1.10 → 2.0

Comment 7

6 years ago
since es-ES is getting about 1:1 downloads in argentina, and has about 2:1 active daily users on es-ES we should look at doing things differently.

we need to find what search results users in Argentina are getting and how they end up only seeing, or downloading es-ES about 50% of the time.   the es-ES download pages might also be improved by showing something like 

 "Did you know a spanish version is also available for users in Argintina, Mexico, and other Spanish Speaking countries?"  

with links to the other versions we have available.

We have the same situation in Mexico with about the same download and adu ratios.
Changing title due to comment #7  since QA does not have search traffic data
Assignee: mozbugs.retornam → nobody
Summary: QA Only - Please help verify locale detection → Please help verify locale detection
(Reporter)

Comment 9

6 years ago
(In reply to chris hofmann from comment #7)
> since es-ES is getting about 1:1 downloads in argentina, and has about 2:1
> active daily users on es-ES we should look at doing things differently.
> 
> we need to find what search results users in Argentina are getting and how
> they end up only seeing, or downloading es-ES about 50% of the time.   the
> es-ES download pages might also be improved by showing something like 

I'm a bit confused. In comment 4 Pascal states: "We offer downloads based on the language they currently use in their browser, if I live in Argentina but use IE in Portuguese, I will get offered a Portuguese download."

This would suggest these users download the inaccurate localization due to their incumbent browsers language, not on that users location, or anything related to search results. Or Chofmann, am I missing something? 

>  "Did you know a spanish version is also available for users in Argintina,
> Mexico, and other Spanish Speaking countries?"  

Agree - doing this should help the problem, regardless of the problems root cause. 

> with links to the other versions we have available.
> 
> We have the same situation in Mexico with about the same download and adu
> ratios.

Comment 10

6 years ago
(In reply to Laura Forrest from comment #9)
> (In reply to chris hofmann from comment #7)
> > since es-ES is getting about 1:1 downloads in argentina, and has about 2:1
> > active daily users on es-ES we should look at doing things differently.
> > 
> > we need to find what search results users in Argentina are getting and how
> > they end up only seeing, or downloading es-ES about 50% of the time.   the
> > es-ES download pages might also be improved by showing something like 
> 
> I'm a bit confused. In comment 4 Pascal states: "We offer downloads based on
> the language they currently use in their browser, if I live in Argentina but
> use IE in Portuguese, I will get offered a Portuguese download."
> 
> This would suggest these users download the inaccurate localization due to
> their incumbent browsers language, not on that users location, or anything
> related to search results. Or Chofmann, am I missing something? 
> 

The case that pascal isn't all that relevant.  Its es-* versions that are in play for the majority of situations.   If an IE user seeking browser alturnatives is probably using es-ES since it doesn't look like microsoft offers es-AR

http://windows.microsoft.com/es-ES/internet-explorer/products/ie/home  (download)
http://windows.microsoft.com/es-AR/internet-explorer/products/ie/home   (404)

So for that case we currently offer all users coming from IE in argentina and mexico an es-ES version since we do only browser detection.

> >  "Did you know a spanish version is also available for users in Argintina,
> > Mexico, and other Spanish Speaking countries?"  
> 
> Agree - doing this should help the problem, regardless of the problems root
> cause. 
> 

I think this is mostly the problem and we could fix with a message like this, or do geolocation detection to spot the combination of es-ES and locations outside of mexico.   We could also think about snippets on the start pages and other places migrate users over to a version that might be better suited to them, and is beyond the choices offered by microsoft.
> > with links to the other versions we have available.
> > 
> > We have the same situation in Mexico with about the same download and adu
> > ratios.
Internet Explorer is preinstalled in Windows, the locale code of Internet Explorer is the locale code of Windows since IE7
http://blogs.msdn.com/b/ie/archive/2006/10/17/accept-language-header-for-internet-explorer-7.aspx

This is something I had tested with our localizers in South America several years ago. I don't know how far Microsoft goes with the translation itself, they probably actually do more a neutral Spanish version that they slightly tweak for markets (similar to en-GB versus en-US).

Also, Microsoft does not use the same url for downloads, they have a special site for IE9 in es-AR promoted on Microsoft Argentina website:
http://www.todoexplorer.com/?ocid=MSCOM_AR#/intro/os_other

I'll see with out Spanish speaking community for the transkation of this string to put it below the download box, this looks like the simplest method. That said, if we tell es-ES users that other es-* versions exists, we should also tell es-* users that es-ES exists, the snippet should mention all the other spanishes we propose such as:

on es-ES:
¿Sabías que también existe Firefox en espańol de Argentina, México y Chile?
on es-CL:
¿Sabías que también existe Firefox en espańol de Argentina, México y Chile?
on es-AR:
¿Sabías que también existe Firefox en espańol de España, México y Chile?
on es-MX:
¿Sabías que también existe Firefox en espańol de Argentina, España y Chile?

Each country could be a download link to the download page.
Do we need to regroup and nail down a solution for this? Not sure what the next steps are.

Comment 13

6 years ago
> I'll see with out Spanish speaking community for the transkation of this string to
> put it below the download box, this looks like the simplest method.

this sounds like a good solution.   we should get a mock up going, push it out and measure.
This is something we could work with the localizers directly at Mozcamp LATAM I think
Pascal, assigning over to you. Sounds like you have a solution and can implement.
Assignee: nobody → pascalc
Target Milestone: 2.0 → 2.3
(Assignee)

Updated

6 years ago
Component: www.mozilla.org/firefox → www.mozilla.org
Product: Websites → Websites

Updated

6 years ago
Target Milestone: 2.3 → 2.9

Comment 16

6 years ago
we've had some trouble with geo-ip issues so these numbers might not be totally right, but reflect the idea that around 50% of download requests for Spanish versions come from Spanish speaking users outside Mexico, Spain, and Argentina.

http://people.mozilla.org/~chofmann/project-metrics/downloads-per-day-from-spanish-speaking-countries.png

We also need to spend some time figuring out what versions are best to be directing these user to as well.
(Assignee)

Updated

6 years ago
Component: www.mozilla.org → General
Product: Websites → www.mozilla.org
I am going to unassign myself from this bug since it is not clear what the next steps are and in the meantime we entirely rewrote mozilla.org, moved to another framework and merged most of our public sites under the same codebase as mozilla.org. We do have some geoIP capabilities in the new site and it is probably possible to tweak the download process for Spanish to propose different builds but we should probably do that as part of some A/B testing and also measure the impact.
Assignee: pascalc → nobody

Updated

2 years ago
Whiteboard: [kb=1830821]
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.