turn some or all cycle collector faults into release mode asserts

RESOLVED DUPLICATE of bug 521853

Status

()

Core
XPCOM
RESOLVED DUPLICATE of bug 521853
6 years ago
6 years ago

People

(Reporter: mccr8, Unassigned)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

6 years ago
The cycle collector has a Fault method that does NS_NOTREACHED, but some of the places this can happen are pretty scary, so we should crash the browser instead of silently shutting down the CC and continuing onwards. I'd probably want to land this early next cycle.
bsmedberg gave me an r+ over IRC to do this, I just never did it.
(Reporter)

Comment 2

6 years ago
Do you have a bug and/or patch for it?
https://bugzilla.mozilla.org/show_bug.cgi?id=521853#c4

I didn't write a patch, but it should be easy.
(Reporter)

Updated

6 years ago
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 521853
You need to log in before you can comment on or make changes to this bug.