Closed Bug 733602 Opened 8 years ago Closed 8 years ago

Various StringBuffer code tweaks

Categories

(Core :: JavaScript Engine, defect, minor)

defect
Not set
minor

Tracking

()

RESOLVED FIXED
mozilla13

People

(Reporter: Waldo, Assigned: Waldo)

References

Details

Attachments

(1 file)

Attached patch PatchSplinter Review
I cleaned up some code while looking at the claimed perf regression in bug 724736, moving StringBuffer-y stuff into the StringBuffer code and removing a bunch of unimplemented and/or unused methods (all of which existed before that bug, note).  Nothing big, just minor hygienic stuff.

(Note that I didn't move NumberValueToStringBuffer over because it has some dependencies on things like ToCStringBuf that are a bit tied into the jsnum code at the moment.  Maybe it should move eventually, but it's not worth any trouble right now.)
Attachment #603491 - Flags: review?(luke)
Attachment #603491 - Flags: review?(luke) → review+
https://hg.mozilla.org/mozilla-central/rev/9d4c267630d4
Status: ASSIGNED → RESOLVED
Closed: 8 years ago
Resolution: --- → FIXED
Depends on: 735313
You need to log in before you can comment on or make changes to this bug.