Zombie compartment if Firefox gets started from CLI and Ghostery 2.7.1 and Adblock Plus 2.0.3 installed

RESOLVED DUPLICATE of bug 718375

Status

()

Firefox
Extension Compatibility
RESOLVED DUPLICATE of bug 718375
6 years ago
6 years ago

People

(Reporter: whimboo, Unassigned)

Tracking

({memory-leak})

10 Branch
All
Mac OS X
memory-leak
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [MemShrink:P3], URL)

Mozilla/5.0 (Macintosh; Intel Mac OS X 10.7; rv:10.0) Gecko/20100101 Firefox/10.0

This issue is kinda strange and I'm not fully sure how it gets triggered. I tried to nail it down a bit and ended up with the steps below. If someone else can try to get closer to the reason it would be appreciated. I have tested it on OS X with Nightly, Aurora, Beta, and latest 10.0 Release. All show the same behavior.

Steps:
1. Create a fresh profile
2. Install Adblock Plus 2.0.3, restart, and subscribe to "EasyList Germany + EasyList"
3. Install Ghostery 2.7.1, restart, and click through the setup without changing anything
4. Open the URL as given in the URL field
5. Open 'about:memory?verbose'
6. Close Firefox
7. Start Firefox again via the command line
8. Restore the session and load the Twitter page
9. Check that the Twitter compartment is shown in about:memory
10. Close the Twitter tab 
11. Click multiple times on 'Minimize memory usage'

With step 11 the compartment never gets removed and stays there forever.

The following variations do not cause a zombie compartment:
* Start Firefox via a dock icon or Quicksilver
* One of the mentioned extensions has not been installed or is disabled
* The given filter list for Adblock hasn't been subscribed
* Exchanging 

I haven't tested on other platforms so I can't say if it's a cross platform issue. Also not sure if one of the extensions is causing it or if it is a core Firefox issue. I don't understand why it is only happening when starting Firefox via the Terminal.

Comment 1

6 years ago
Ghostery stuff is being tracked in this ticket: https://bugzilla.mozilla.org/show_bug.cgi?id=718375
Henrik, can you still reproduce this?  Ghostery 2.7.2 fixed some other leaks.
Whiteboard: [MemShrink] → [MemShrink:P3]
I can't reproduce it anymore with Ghostery 2.7.2 installed. So lets mark as dupe of bug 718375.
Assignee: general → nobody
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Component: JavaScript Engine → Extension Compatibility
Product: Core → Firefox
QA Contact: general → extension.compatibility
Resolution: --- → DUPLICATE
Duplicate of bug: 718375
You need to log in before you can comment on or make changes to this bug.