-moz-column-fill: balance; does not work sometimes

RESOLVED WORKSFORME

Status

()

Core
Layout
RESOLVED WORKSFORME
6 years ago
4 years ago

People

(Reporter: Alice0775 White, Unassigned)

Tracking

({regression})

12 Branch
x86
All
regression
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

6 years ago
Created attachment 603654 [details]
sample html

Build Identifier:
http://hg.mozilla.org/mozilla-central/rev/7d0d1108a14e
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:13.0) Gecko/20120306 Firefox/13.0a1 ID:20120306031101

I encounter a problem when I test Bug 731516.
-moz-column-fill: balance; does not work sometimes.
This happens on Windows7 and Ubuntu10.40.

Reproducible: Always

Steps to Reproduce #1:
1. Start Minefield with new profile
2. Open Error console(Ctrl+Shift+j)
3. Evaluate top.opener.resizeTo(1250,950); in Error Console
4. Open sample html
   --- last column does not seem to balance
5. Evaluate top.opener.resizeTo(850,950); top.opener.resizeTo(1250,950); in Error Console.
   --- last column does not seem to balance
6. Resize browser width a little by dragging browsr border
   --- last column seems to balance now

Actual Results:
 @Step 4, 5.
 last column does not seem to balance

Expected Results:  
 @Step 4, 5.
 last column should be balance

Regression window(m-i),
Works:
http://hg.mozilla.org/mozilla-central/rev/0b4c58200e3a
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:12.0a1) Gecko/20120117 Firefox/12.0a1 ID:20120117042508
Fails:
http://hg.mozilla.org/mozilla-central/rev/ff1bedd7d463
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:12.0a1) Gecko/20120117 Firefox/12.0a1 ID:20120117072408
Pushlog:
http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=0b4c58200e3a&tochange=ff1bedd7d463

Regression window(m-i),
Works:
http://hg.mozilla.org/integration/mozilla-inbound/rev/7ea3311b5e6c
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:12.0a1) Gecko/20120116 Firefox/12.0a1 ID:20120116145408
Fails:
http://hg.mozilla.org/integration/mozilla-inbound/rev/3077b729dfd5
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:12.0a1) Gecko/20120116 Firefox/12.0a1 ID:20120116153908
Pushlog:
http://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=7ea3311b5e6c&tochange=3077b729dfd5

First bad changset:
7f8cf8e934a5	Benjamin Stover — Bug 665597 - Include margin calculations in FinishAndStoreOverflow. part=1/5 r=roc
Assignee: nobody → matspal
Seems to work for me in a current Nightly on Linux64, possibly because of the
wallpaper in bug 750293 to not include the margin in scrollable overflow for now.
I suspect this problem will resurface once we fix that bug properly.  Marking
dependent for now.

Still, I don't see why column balancing would be affected exactly.
Assignee: matspal → nobody
Depends on: 750293
(Reporter)

Comment 2

4 years ago
WFM on Firefox30
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.