All users were logged out of Bugzilla on October 13th, 2018

Conversation threading: reduce nesting in conversation view

RESOLVED DUPLICATE of bug 459659

Status

RESOLVED DUPLICATE of bug 459659
7 years ago
5 years ago

People

(Reporter: arkadiy_s, Unassigned)

Tracking

(Depends on: 1 bug)

10 Branch
x86_64
Windows 7

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Reporter)

Description

7 years ago
Created attachment 603662 [details]
Conversations.png

User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:11.0) Gecko/20100101 Firefox/11.0
Build ID: 20120222074758

Steps to reproduce:

Participated in a long conversation


Actual results:

The message list has become very difficult to use


Expected results:

Display a list of messages in the form of a linear list when possible
(Reporter)

Comment 1

7 years ago
Created attachment 603663 [details]
Example of how I wanted this to work
Did you try the conversation extension ?

Comment 3

7 years ago
If you don't want real threading, you could try grouping by subject, which is fairly similar but doesn't do any nesting beyond the first level.

We could flatten out the threading after a certain level (not at the first level like you've shown), but to do it right we'd probably want to know how wide the subject column is, which makes it tricky.
(Reporter)

Comment 4

7 years ago
(In reply to Ludovic Hirlimann [:Usul] from comment #2)
> Did you try the conversation extension ?

Which extension you mean? I use Thunderbird Conversations extension
(Reporter)

Comment 5

7 years ago
(In reply to David :Bienvenu from comment #3)
> If you don't want real threading, you could try grouping by subject, which
> is fairly similar but doesn't do any nesting beyond the first level.
> 
> We could flatten out the threading after a certain level (not at the first
> level like you've shown), but to do it right we'd probably want to know how
> wide the subject column is, which makes it tricky.

I prefer the sorts of discussions for other discussions, but for some of it does not work very well.

I want only flatten discussions only with one reply at level, we shouldn't flatten discussion level with several replies.

Comment 6

5 years ago
Other suggestions:
- Reduce the indentation width as far as there is at least a sufficiant part of the messages subjects visible.
- Bug 871486.

Updated

5 years ago
Depends on: 871486

Updated

5 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 459659
You need to log in before you can comment on or make changes to this bug.