If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

[traceback] list index out of range in the validator

RESOLVED DUPLICATE of bug 729316

Status

addons.mozilla.org Graveyard
Add-on Validation
RESOLVED DUPLICATE of bug 729316
6 years ago
2 years ago

People

(Reporter: clouserw, Assigned: basta)

Tracking

unspecified
6.4.6

Details

(Reporter)

Description

6 years ago
Got this traceback this morning.  It suggests the file id is 101118 I think if you need a .xpi to play with.  I can help get it for you.

Task zadmin.tasks.bulk_validate_file with id b58c94ba-a74c-46d1-96f4-af1d6a2bd0a6 raised exception:
"IndexError('list index out of range',)"


Task was called with args: (101118L,) kwargs: {}.

The contents of the full traceback was:

Traceback (most recent call last):
  File "/data/www/addons-dev.allizom.org/zamboni/vendor/lib/python/celery/execute/trace.py", line 34, in trace
    return cls(states.SUCCESS, retval=fun(*args, **kwargs))
  File "/data/www/addons-dev.allizom.org/zamboni/vendor/lib/python/celery/task/base.py", line 241, in __call__
    return self.run(*args, **kwargs)
  File "/data/www/addons-dev.allizom.org/zamboni/vendor/lib/python/celery/app/__init__.py", line 141, in run
    return fun(*args, **kwargs)
  File "/data/www/addons-dev.allizom.org/zamboni/vendor/src/nuggets/celeryutils.py", line 35, in wrapped
    return fun(*args, **kw)
  File "/data/www/addons-dev.allizom.org/zamboni/apps/amo/decorators.py", line 112, in wrapper
    return f(*args, **kw)
  File "/data/www/addons-dev.allizom.org/zamboni/apps/amo/decorators.py", line 104, in wrapper
    return f(*args, **kw)
  File "/data/www/addons-dev.allizom.org/zamboni/apps/zadmin/tasks.py", line 93, in bulk_validate_file
    test_all_tiers=True, overrides=overrides)
  File "/data/www/addons-dev.allizom.org/zamboni/apps/devhub/tasks.py", line 154, in run_validator
    timeout=settings.VALIDATOR_TIMEOUT)
  File "/data/www/addons-dev.allizom.org/zamboni/vendor/src/amo-validator/validator/validate.py", line 47, in validate
    timeout=timeout)
  File "/data/www/addons-dev.allizom.org/zamboni/vendor/src/amo-validator/validator/submain.py", line 91, in prepare_package
    for_appversions)
  File "/data/www/addons-dev.allizom.org/zamboni/vendor/src/amo-validator/validator/submain.py", line 171, in test_package
    output = test_inner_package(err, package, for_appversions)
  File "/data/www/addons-dev.allizom.org/zamboni/vendor/src/amo-validator/validator/submain.py", line 341, in test_inner_package
    test_func(err)
  File "/data/www/addons-dev.allizom.org/zamboni/vendor/src/amo-validator/validator/testcases/chromemanifest.py", line 88, in test_content_instructions
    elif not triple["object"].split()[0].endswith("/"):
IndexError: list index out of range
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 729316
Product: addons.mozilla.org → addons.mozilla.org Graveyard
You need to log in before you can comment on or make changes to this bug.