Yammer captures Ctrl-T & Ctrl-C

RESOLVED FIXED

Status

RESOLVED FIXED
7 years ago
4 years ago

People

(Reporter: jsocol, Assigned: mbrubeck)

Tracking

Details

(Reporter)

Description

7 years ago
I can't open a new tab from within Yammer by hitting Ctrl-T unless a textarea or other input has focus. Other people reported similar things: https://www.yammer.com/mozilla.com/#/Threads/show?threadId=155167577

I've only noticed this in the past couple of days, but I'm not sure how far back it goes. I'm using Nightly on Windows 7 (about:buildconfig says it's this changeset: http://hg.mozilla.org/mozilla-central/rev/78e56fd22f2a). Others mentioned it in Aurora.

For me it's consistent, other people report it intermittently. It happens for me both as an app tab and a regular tab--others reported differently.

That's not a lot of info to go on, I know. Happy to help.
Is there a plugin area (e.g. flash) on that page ?
It captures Ctrl-C for me on WinXP/Aurora as well - makes it a pain to copy text.

Comment 3

7 years ago
Tracking for FF12 as we try to understand whether this is a regression in Firefox or a change to the website.
tracking-firefox12: --- → +
Keywords: qawanted, regressionwindow-wanted
(Assignee)

Comment 4

7 years ago
(In reply to Alex Keybl [:akeybl] from comment #3)
> Tracking for FF12 as we try to understand whether this is a regression in
> Firefox or a change to the website.

This is not regression in Firefox 12.  It's likely a site change.  I can reproduce this bug in Firefox 10 (but not in Chromium -- so either they run different code in Chromium or Chromium itself differs in some relevant way).

"C" and "T" are among the keys used as keyboard shortcuts by Yammer.  (Press "?" within Yammer for a list.)  It looks like Yammer captures key events for all of those keys, even while modifier keys are down.
Keywords: regressionwindow-wanted
(Assignee)

Updated

7 years ago
Depends on: 735113
(Assignee)

Comment 5

7 years ago
Moving this to Tech Evangelism because this appears to be a Yammer bug.  I will file a Yammer help request, and I'll also see if we have anyone with contacts at Yammer.

I also filed bug 735113 as a non-Yammer-specific request to prevent any page from overriding important Firefox key commands like Control-T.
Assignee: nobody → english-us
Component: General → English US
Product: Firefox → Tech Evangelism
QA Contact: general → english-us
(Assignee)

Comment 6

7 years ago
mrz, do you know the best way to submit a bug report to Yammer?
Assignee: english-us → mbrubeck
Status: NEW → ASSIGNED
(Assignee)

Comment 7

7 years ago
For now I submitted https://yammer.zendesk.com/requests/51807 (which might not be visible to anyone except me).
(Assignee)

Comment 8

7 years ago
Yammer responded that this is a known issue with a fix in progress.

I'm removing tracking-firefox12 because this is not a Firefox issue.
tracking-firefox12: + → ---
Summary: Yammer captures Ctrl-T → Yammer captures Ctrl-T & Ctrl-C
(Assignee)

Comment 9

7 years ago
This was fixed by Yammer.
Status: ASSIGNED → RESOLVED
Last Resolved: 7 years ago
Keywords: qawanted
Resolution: --- → FIXED
Product: Tech Evangelism → Tech Evangelism Graveyard
You need to log in before you can comment on or make changes to this bug.