Khronos test "Context creation and destruction" hang and sometimes crash @ mozalloc_abort | NS_DebugBreak_P | mozilla::gl::GLContext::InitWithPrefix

RESOLVED WORKSFORME

Status

()

Core
Canvas: WebGL
--
critical
RESOLVED WORKSFORME
6 years ago
2 years ago

People

(Reporter: Theliel, Unassigned)

Tracking

({crash})

13 Branch
x86_64
Windows 7
crash
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(crash signature, URL)

(Reporter)

Description

6 years ago
Firefox: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:13.0) Gecko/20120307 Firefox/13.0a1
WebGL: ANGLE 1.0.0.963
Video: nVidia GTX 460 1G - 295.73

Context creation and destruction text from khronos blocks several times for some seconds the whole system, and ends shutting down Firefox with crash.

In some others situations, the test finished with a timeout but dont crash Firefox.


Expected result: Pass or fail the test
(Reporter)

Updated

6 years ago
Summary: Khronos test "Context creation and destruction" hang and Crash Firefox → @ mozalloc_abort(char const* const) | NS_DebugBreak_P | mozilla::gl::GLContext::InitWithPrefix(char const*, bool) Khronos test "Context creation and destruction" hang and Crash Firefox
(Reporter)

Comment 1

6 years ago
Edit:

Test consume all Physical RAM(6GB in my case) and system close because insufficiency virtual memory.

Setting WebGL to native work fine, the test use a lot of memory too, but work after all, and pass all 500 subtest, so the problem should be ANGLE.

Comment 2

6 years ago
It hangs for me (4GB of RAM).
Can you provide crash IDs?
Severity: normal → critical
Keywords: crash
Summary: @ mozalloc_abort(char const* const) | NS_DebugBreak_P | mozilla::gl::GLContext::InitWithPrefix(char const*, bool) Khronos test "Context creation and destruction" hang and Crash Firefox → Khronos test "Context creation and destruction" hang and sometimes crash @ mozalloc_abort | NS_DebugBreak_P | mozilla::gl::GLContext::InitWithPrefix
Crashes for me on my home machine running win7 aurora. 16GB RAM, and it does look like it's chewing through about its 32-bit max before crashing. I'll try to repro on my work computer with trunk tomorrow or Friday.
This fell through the cracks.
Symptom from #c2 is a dupe of bug 732765, but fixing that should simply result in a different crash type.
Status: UNCONFIRMED → NEW
Ever confirmed: true

Updated

2 years ago
Crash Signature: [@ mozalloc_abort(char const* const) | NS_DebugBreak_P | mozilla::gl::GLContext::InitWithPrefix(char const*, bool) ] → [@ mozalloc_abort(char const* const) | NS_DebugBreak_P | mozilla::gl::GLContext::InitWithPrefix(char const*, bool) ] [@ mozalloc_abort | NS_DebugBreak_P | mozilla::gl::GLContext::InitWithPrefix ]
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → WORKSFORME
Mass resolving WFM: signature(s) hasn't(/haven't) reported in past 28 days.
You need to log in before you can comment on or make changes to this bug.