Last Comment Bug 734045 - GCLI resource doesn't always find script tags
: GCLI resource doesn't always find script tags
Status: RESOLVED FIXED
[fixed-in-fx-team]
:
Product: Firefox
Classification: Client Software
Component: Developer Tools: Console (show other bugs)
: unspecified
: All All
: P3 normal (vote)
: Firefox 15
Assigned To: Joe Walker [:jwalker] (needinfo me or ping on irc)
:
Mentors:
Depends on:
Blocks: 745773
  Show dependency treegraph
 
Reported: 2012-03-08 04:41 PST by Joe Walker [:jwalker] (needinfo me or ping on irc)
Modified: 2012-06-02 16:58 PDT (History)
1 user (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Upload 1 (2.46 KB, patch)
2012-05-31 02:57 PDT, Joe Walker [:jwalker] (needinfo me or ping on irc)
dcamp: review+
Details | Diff | Review

Description Joe Walker [:jwalker] (needinfo me or ping on irc) 2012-03-08 04:41:16 PST
>>> document.body.querySelectorAll("script");
undefined

>>> document.body.getElementsByTagName("script");
undefined

>>> document.body.children[5];
<script src="scripts/require.js" type="text/javascript">
Comment 1 Joe Walker [:jwalker] (needinfo me or ping on irc) 2012-04-29 11:29:50 PDT
GCLI Triage.
Comment 2 Joe Walker [:jwalker] (needinfo me or ping on irc) 2012-05-31 02:57:27 PDT
Created attachment 628648 [details] [diff] [review]
Upload 1

Turns out this was a test failure.
This is trivial enough that I'm not going to bother with a pull request.

But for your delectation, the commit message:

    Bug 734045 (script0): Use getLookup not getPredictions
    
    The results of getPredictions are filtered through the matcher which
    prevents the return of more than 10 results, so it's silly doing maths on
    the lengths expecting it to work. Instead we should be using getLookup
    directly which isn't filtered, and so the length maths will work.
Comment 3 Joe Walker [:jwalker] (needinfo me or ping on irc) 2012-06-02 03:17:33 PDT
https://tbpl.mozilla.org/?tree=Fx-Team&rev=c9b7a566ff05
Comment 4 Joe Walker [:jwalker] (needinfo me or ping on irc) 2012-06-02 03:18:17 PDT
(Also fwiw: https://tbpl.mozilla.org/?tree=Try&rev=3e09d6ee6d89)
Comment 5 Dave Camp (:dcamp) 2012-06-02 16:58:52 PDT
https://hg.mozilla.org/mozilla-central/rev/c9b7a566ff05

Note You need to log in before you can comment on or make changes to this bug.