If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

If <li> element contains <a> and block element, strange space will appear at top of li element

RESOLVED DUPLICATE of bug 516192

Status

()

Core
Layout: Block and Inline
RESOLVED DUPLICATE of bug 516192
6 years ago
6 years ago

People

(Reporter: hail2u@gmail.com, Unassigned)

Tracking

10 Branch
x86_64
Windows 7
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

6 years ago
User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64) AppleWebKit/535.11 (KHTML, like Gecko) Chrome/17.0.963.65 Safari/535.11

Steps to reproduce:

I create a simple lists that contains `a` and block (`p`) element like that:
http://hail2u.net/pub/test/386.html


Actual results:

A strange space appears at top of list item on Firefox 10 and 12 (Aurora).


Expected results:

Block element should be aligned at top of list item.

Comment 1

6 years ago
Do you mean the odd pink lines on the top and bottom left corners?

Comment 2

6 years ago
Add display: block; to your a element to fix the immediate issue.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 516192
You need to log in before you can comment on or make changes to this bug.