Closed Bug 734053 Opened 8 years ago Closed 8 years ago

Add-ons are not listed in Add-ons Manager

Categories

(Firefox for Android :: General, defect)

13 Branch
ARM
Android
defect
Not set

Tracking

()

VERIFIED FIXED
Firefox 13
Tracking Status
firefox13 --- verified
blocking-fennec1.0 --- beta+

People

(Reporter: andreea.pod, Assigned: Margaret)

References

Details

(Keywords: regression)

Attachments

(1 file)

Build: Firefox 13.0a1 (2012-03-08)
Device: LG Optimus 2X (Android 2.2)

Steps to reproduce:
1. Open Fennec
2. Go to about:addons

Expected results:
- default search engines should appear. If you have other add-ons installed you should be able to see it.

Actual result:
- no add-ons present in the Add-ons Manager.
do you see any errors in the logcat?
blocking-fennec1.0: --- → ?
blocking-fennec1.0: ? → beta+
Assignee: nobody → margaret.leibovic
I'm suspicious of bug 731041. mbrubeck, do you remember testing that patch when you reviewed it?
Yup, backing out those two patches fixes the problem. I'll try to investigate precisely what went wrong.
Blocks: 731041
I tested an earlier version of those patches, but I probably tested it in XUL Fennec only.  (It also would be good to know whether XUL Fennec is affected by this regression.)
The problem is in here:
http://hg.mozilla.org/mozilla-central/diff/87d12a41e3e0/mobile/android/chrome/content/aboutAddons.js

The error is:
[JavaScript Error: "in strict mode code, functions may be declared only at top level or immediately within another function" {file: "chrome://browser/content/aboutAddons.js" line: 253 column: 17 source: "        function stripTextNodes(aNode) {
E/GeckoConsole( 4155): "}]
Attached patch patchSplinter Review
This fixes the issue by moving the helper function (I also changed the empty string to be more consistent with the rest of the file).

I don't think this is something we need to worry about in XUL fennec, since I can't spot a "use strict" (can you even do that in XBL?).
Attachment #604248 - Flags: review?(mbrubeck)
Comment on attachment 604248 [details] [diff] [review]
patch

Good catch.  This was caused by a conflict between bug 731041 and bug 730502 (which landed after the patches from 731041 were developed and tested).
Attachment #604248 - Flags: review?(mbrubeck) → review+
https://hg.mozilla.org/mozilla-central/rev/63dce6d751c6
Status: NEW → RESOLVED
Closed: 8 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 13
Verified fixed on:
Nightly Fennec 13.0a1 (2012-03-12)
Device: HTC Desire Z
OS: Android 2.3.3
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.