Closed Bug 734054 Opened 10 years ago Closed 10 years ago

Manage In-App Payments link is missing

Categories

(addons.mozilla.org Graveyard :: Developer Pages, defect)

x86_64
Windows 7
defect
Not set
normal

Tracking

(Not tracked)

VERIFIED FIXED

People

(Reporter: cboldan.mozbugs, Assigned: andy+bugzilla)

References

Details

(Keywords: regression)

Attachments

(4 files)

Attached image manage in app payments
Steps to reproduce:
1. Login to APPS Marketplace https://marketplace-dev.allizom.org/en-US/developers/apps
2. From app list, go to a premium app with in-app payments and verify the available actions under "More" dropdown menu.

Expected restuls:
"Manage In-App Payments" link is present in the more dropdown menu, also in the left menu from the manage app pages.

Actual results:
"Manage In-App Payments" link and page is missing, although user can set up a Free or Premium app with in-app payments.

Notes/Issues:
Attaching screenshot for this issue.
Manage in-app payments link is available only upon selecting that option of payment for your app. Can you check if the link shows up on switching to that payment method?
Yes, the issue is still reproducing. I have set an app with the payment "Premium with in app payments" and the link for Manage In App Payments is not showing up http://screencast.com/t/bKE97vKI
In-app payments switch was off. Probably due to the copy from prod. Which begs the question, is this off on prod?
Status: NEW → RESOLVED
Closed: 10 years ago
Resolution: --- → FIXED
Assignee: nobody → amckay
Verified as fixed in https://marketplace-dev.allizom.org/en-US/developers/apps
Could not verify on production because of the bug 732362.
Attaching postfix screenshot for this issue.
Closing bug.
Status: RESOLVED → VERIFIED
Attached image postfix in app payments
In App payments is switched off in production https://marketplace.mozilla.org/en-US/developers
It is not reproducible on staging.
Attaching screenshot for production.
Status: VERIFIED → REOPENED
Keywords: regression
Resolution: FIXED → ---
The switch has been enabled in production. Can you check now?
Status: REOPENED → RESOLVED
Closed: 10 years ago10 years ago
Resolution: --- → FIXED
In App Payments is not working in both staging and production.
Verified as fixed in https://marketplace.mozilla.org/en-US/developers
Attaching postfix screenshot.
Closing bug.
Status: RESOLVED → VERIFIED
Product: addons.mozilla.org → addons.mozilla.org Graveyard
You need to log in before you can comment on or make changes to this bug.