Closing FF in Private mode close also the bookmarks panel

RESOLVED WORKSFORME

Status

()

Core
XUL
RESOLVED WORKSFORME
6 years ago
4 years ago

People

(Reporter: MikkCZ, Unassigned)

Tracking

10 Branch
x86_64
Windows 7
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:10.0.2) Gecko/20100101 Firefox/10.0.2
Build ID: 20120215223356

Steps to reproduce:

1. Start Firefox.
2. Open Bookmarks panel.
3. Run Private mode.
4. Close Firefox (with Private mode activated).
5. Run Firefox again and...the Bookmarks panel is closed (as in the Private mode is).


Actual results:

If you switch to Normal mode before closing FF, the Bookmarks panel appears again and after the restart it stays opened.


Expected results:

IMHO Firefox should hide the Bookmarks panel when it's in Private mode, but after restart the panel should be reopened.
Component: Untriaged → Private Browsing

Updated

6 years ago
QA Contact: untriaged → private.browsing

Comment 1

6 years ago
Why should we hide the bookmarks panel?
The hiding feature is not important. The main reason why I fill this bug, is to open it after restart, if it had been opened before switching to private mode.

Comment 3

6 years ago
So I just did the following:

1. Started Firefox.
2. Opened the bookmarks sidebar.
3. Switched into private browsing mode.
4. Quit Firefox.
5. Started it again.

The bookmark sidebar is opened at step 5.  Is there something I'm missing here?
In my case the sidebar stays closed.
I have created also a new virtual WinXP computer with clear FF installation, but it doesn't work there either.

Can someone else check it and confirm, what behavior is normal?

Comment 5

6 years ago
Weird, I can't reproduce myself...
Keywords: qawanted
Using Mozilla/5.0 (Macintosh; Intel Mac OS X 10.6; rv:12.0) Gecko/20100101 Firefox/12.0, I haven't be able to reproduce this either. Will try on a different machine.
(In reply to Marcia Knous [:marcia] from comment #6)
> Using Mozilla/5.0 (Macintosh; Intel Mac OS X 10.6; rv:12.0) Gecko/20100101
> Firefox/12.0, I haven't be able to reproduce this either. Will try on a
> different machine.

I am not able to test it on Mac - maybe it's occurs at Windows only.

Comment 8

6 years ago
Paul, are you aware whether the sessionrestore component is the one handling the bookmarks side bar?
(In reply to Ehsan Akhgari [:ehsan] from comment #8)
> Paul, are you aware whether the sessionrestore component is the one handling
> the bookmarks side bar?

I think that's persisted via localstore.rdf.

I think the issue is the difference between quitting & closing the last window to quit. I can reproduce on Linux when closing the last window to quit. But if I quit through File > Exit, then things work as expected.

Comment 10

6 years ago
Do you know what component is responsible for localstore.rdf?
Core > XUL I think

nsXULDocument::Persist is where it ultimately happens, but there may be another layer on top controlling when that gets called.

Updated

6 years ago
Component: Private Browsing → XUL
Product: Firefox → Core
QA Contact: private.browsing → xptoolkit.widgets
Duplicate of this bug: 722349
What's need from QA on this bug, if anything?

Comment 14

6 years ago
(In reply to Anthony Hughes, Mozilla QA (irc: ashughes) from comment #13)
> What's need from QA on this bug, if anything?

Nothing, forgot to clear the flag.
Keywords: qawanted
As Firefox now opens entire private windows, this bug is no more reproducible.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.