Closed Bug 734350 Opened 11 years ago Closed 11 years ago

private browsing mode permanently sets icons for visited dynamic bookmarks

Categories

(Firefox :: Private Browsing, defect)

x86_64
Linux
defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 613588

People

(Reporter: cobinja, Unassigned)

References

Details

When visiting a dynamic bookmark link in private browsing mode, the favicon is set. After exiting private browsing by closing the only open firefox window and restarting in normal mode, the favicon is still visible so that one can see that this link was visited.

The favicon should not be visible after exiting private browsing mode.

Steps to reproduce:
  -enter private browsing mode
  -visit a link in a dynamic bookmark; the favicon is set
  -exit private browsing mode
  -the favicon is still visible
Reproducible: always
What is a dynamic bookmark?
I suppose he means livemarks, if so, this bug has been fixed by bug 613588. we were indeed using icons before, and since these were considered bookmarks they were bypassing the PB check.
Status: UNCONFIRMED → RESOLVED
Closed: 11 years ago
Depends on: livemarksIO
Resolution: --- → FIXED
With a dynamic bookmark I mean the possibility of subscribing e.g. an RSS feed in the bookmarks (maybe they're called livemarks internally, in the German version of Firefox it's "Dynamisches Lesezeichen"). With favicon I don't mean the general one for RSS feeds, but the site specific one that is assigned when you visit a link in a subscribed RSS feed.

This is not fixed by #613588, it's still an issue in the just released 11. Reopened.
Status: RESOLVED → UNCONFIRMED
Resolution: FIXED → ---
As you can see from the Target Milestone of bug 613588, that bug will be in FF13. Bugs are considered fixed when they hit the development branch, not when they hit the release branch. So your issue will be fixed in Firefox 13.
Status: UNCONFIRMED → RESOLVED
Closed: 11 years ago11 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.