Last Comment Bug 734384 - Trunk build fails, complaining with "nsMsgDBFolder.cpp:179:88: error: no matching function for call to ‘NS_RegisterStaticAtoms(const nsStaticAtom [21], unsigned int)’"
: Trunk build fails, complaining with "nsMsgDBFolder.cpp:179:88: error: no matc...
Status: VERIFIED FIXED
:
Product: Thunderbird
Classification: Client Software
Component: General (show other bugs)
: Trunk
: All All
: -- blocker (vote)
: Thunderbird 13.0
Assigned To: Mike Conley (:mconley) - (needinfo me!)
:
Mentors:
Depends on:
Blocks: 696242
  Show dependency treegraph
 
Reported: 2012-03-09 07:27 PST by Mike Conley (:mconley) - (needinfo me!)
Modified: 2012-03-09 15:42 PST (History)
1 user (show)
bugzillamozillaorg_serge_20140323: in‑testsuite-
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---


Attachments
Patch (527 bytes, patch)
2012-03-09 10:22 PST, Mike Conley (:mconley) - (needinfo me!)
no flags Details | Diff | Splinter Review

Description Mike Conley (:mconley) - (needinfo me!) 2012-03-09 07:27:39 PST
Trunk builds are failing with:

/buildbot/linux-comm-central-build/build/mailnews/base/util/nsMsgDBFolder.cpp: In constructor ‘nsMsgDBFolder::nsMsgDBFolder()’:
/buildbot/linux-comm-central-build/build/mailnews/base/util/nsMsgDBFolder.cpp:179:88: error: no matching function for call to ‘NS_RegisterStaticAtoms(const nsStaticAtom [21], unsigned int)’
NEXT ERROR make[6]: *** [nsMsgDBFolder.o] Error 1
make[6]: Leaving directory `/buildbot/linux-comm-central-build/build/objdir-tb/mailnews/base/util'
NEXT ERROR make[5]: *** [util_libs] Error 2

I'm pretty sure Bug 696242 is the cause.
Comment 1 Mike Conley (:mconley) - (needinfo me!) 2012-03-09 10:22:47 PST
Created attachment 604453 [details] [diff] [review]
Patch

Already committed with r=bustage-fix, but for bookkeeping, here's the patch I put up anyhow.

Committed to comm-central as http://hg.mozilla.org/comm-central/rev/164813226897
Comment 2 Serge Gautherie (:sgautherie) 2012-03-09 15:42:44 PST
V.Fixed

Note You need to log in before you can comment on or make changes to this bug.