Cache explorer freezes Firefox

RESOLVED DUPLICATE of bug 165821

Status

()

Core
Networking: Cache
RESOLVED DUPLICATE of bug 165821
6 years ago
6 years ago

People

(Reporter: Joan, Unassigned)

Tracking

10 Branch
x86_64
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

6 years ago
User Agent: Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:10.0.2) Gecko/20100101 Firefox/10.0.2
Build ID: 20120216100510

Steps to reproduce:

I went to about:cache, and clicked "list cache entries" for "Disk cache".


Actual results:

Firefox freezed due to having about 16000 entries, weighing 250 megabytes. Regarding "freeze": on an Ubuntu machine, the window became more black, and firefox was irresponsive. I had just enough time to close the tab.


Expected results:

I don't know, maybe showing few entries and allowing to click "more", or adding a search box and loading selectively would be better.
Component: Untriaged → Networking: Cache
Product: Firefox → Core
QA Contact: untriaged → networking.cache
Looks like the old "about:cache needs to be asynch" problem, to me.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 165821
You need to log in before you can comment on or make changes to this bug.