Removing text from the <p></p> in a table, with jeditable and jquery, makes the test page run much slower

RESOLVED WORKSFORME

Status

()

Core
General
RESOLVED WORKSFORME
6 years ago
2 years ago

People

(Reporter: cfiles, Unassigned)

Tracking

({perf})

Trunk
x86
All
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Reporter)

Description

6 years ago
Created attachment 604455 [details]
report.tgz

User Agent: Mozilla/5.0 (X11; Linux i686 on x86_64; rv:10.0.2) Gecko/20100101 Firefox/10.0.2
Build ID: 20120215223356

Steps to reproduce:

I have a really large table that is using jeditable and jquery to edit fields that use paragraph tags <p> to designate what values to change.


Actual results:

If the <p> tags have no text, jquery times out.  That is, it takes way to long.  

If the text fields are filled then it works fine.  

Included is a tar file that has two html files.
working.php.html 
not_working.php.html

The only difference between the two is the text inside the <p> tags.



Expected results:

FYI, Safari and Chrome handle this correctly.

Comment 1

6 years ago
Created attachment 609261 [details]
sample from activity monitor (of a profiling nightly)

Comment 2

6 years ago
Thanks for reporting this issue and for the test files!

I can reproduce on Mac, although the script doesn't hit the "Unresponsive script" warning limit, taking just a few seconds.

The jeditable script asks us the computed width/height of many elements, which takes up most of the time, according to the profile.

Moving to Core on the assumption that the script itself behaves the same on the two testcases / on the different browsers, but this would greatly benefit from a minimized testcase - see https://developer.mozilla.org/en/Reducing_testcases
Component: Untriaged → General
Keywords: perf, testcase-wanted
OS: Linux → All
Product: Firefox → Core
QA Contact: untriaged → general
Summary: <p></p> tag with no text causes jquery to time out → Removing text from the <p></p> in a table, with jeditable and jquery, makes the test page run much slower
Version: 10 Branch → Trunk
Yeah, a reduced testcase would be really useful here....
Keywords: qawanted

Comment 4

5 years ago
WFM on Mozilla/5.0 (X11; Linux x86_64; rv:24.0) Gecko/20100101 Firefox/24.0.

Reporter, can you still reproduce this issue on the latest Firefox versions (24/25/26/27)?
Flags: needinfo?(cfiles)
(Reporter)

Comment 5

5 years ago
Seems to be fixed on version 24.
Flags: needinfo?(cfiles)

Updated

5 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 5 years ago
Keywords: qawanted
Resolution: --- → WORKSFORME
Keywords: testcase-wanted
You need to log in before you can comment on or make changes to this bug.