Last Comment Bug 734447 - Unlocalized redirect article switches locale to en-US on redirect
: Unlocalized redirect article switches locale to en-US on redirect
Status: RESOLVED FIXED
u=user c=wiki p=1
:
Product: support.mozilla.org
Classification: Other
Component: Knowledge Base Software (show other bugs)
: unspecified
: All All
: P2 normal (vote)
: 2012.8
Assigned To: Tanay Gavankar [:tgavankar]
:
:
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-03-09 11:25 PST by Ricky Rosario [:rrosario, :r1cky]
Modified: 2012-05-01 07:07 PDT (History)
3 users (show)
See Also:
QA Whiteboard:
Iteration: ---
Points: ---


Attachments

Description Ricky Rosario [:rrosario, :r1cky] 2012-03-09 11:25:39 PST
STR:
https://support.mozilla.org/pt-PT/kb/how-do-i-stop-websites-tracking-me

redirects to:

https://support.mozilla.org/en-US/kb/how-do-i-turn-do-not-track-feature?redirectlocale=en-US&redirectslug=how-do-i-stop-websites-tracking-me


It should instead keep the user in the pt-PT locale even if the article isn't localized.
Comment 1 Tanay Gavankar [:tgavankar] 2012-03-26 12:21:48 PDT
This bug seems to be underspecified. The full bug that I see is that if an article redirects from from one article to another, it redirects to en-US regardless of the original locale. 

(Just trying to get to an unlocalized article keeps the user in their locale with the "help translate this article" message.)

Is that correct?
Comment 2 Will Kahn-Greene [:willkg] 2012-04-27 15:30:44 PDT
Landed in master in https://github.com/mozilla/kitsune/commit/4d6a8b3c67babdf70fa2caff0383809b793fe37d

Pushed to production just now.

Tanay: Can you double-check it and make sure it works? After that, you can close this out.
Comment 3 Tanay Gavankar [:tgavankar] 2012-05-01 07:07:33 PDT
Works as intended. Marking as RESO FIXED.

Note You need to log in before you can comment on or make changes to this bug.