All users were logged out of Bugzilla on October 13th, 2018

localStorage data should be user specific

RESOLVED WONTFIX

Status

P3
minor
RESOLVED WONTFIX
7 years ago
3 years ago

People

(Reporter: krupa.mozbugs, Unassigned)

Tracking

Details

(Reporter)

Description

7 years ago
steps to reproduce:
1. Log in as User 1
2. Visit the details page for a few collections.
3. Make sure that these collections are listed under 'Recently Viewed Collections'
4. Log in as User 2
5. Check the "Recently Viewed Collections' section

observed behavior:
Collections visited by User 1 are listed for User 2.

screencast: http://screencast.com/t/70ZA185lm
Not tying localStorage data to a particular user is also an issue with discopane recommendations, balloon messages, editor MOTD, and probably more.
(Reporter)

Updated

7 years ago
Summary: Recently Viewed collections should be user specific → localStorage data should be user specific
Severity: major → minor
Priority: -- → P3
Thanks for filing this.  Due to resource constraints we are closing bugs which we won't realistically be able to fix.  If you have a patch that applies to this bug please reopen.

For more info see http://micropipes.com/blog/2014/09/24/the-great-add-on-bug-triage/
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → WONTFIX
(Assignee)

Updated

3 years ago
Product: addons.mozilla.org → addons.mozilla.org Graveyard
You need to log in before you can comment on or make changes to this bug.