Closed Bug 734503 Opened 8 years ago Closed 6 years ago

Add new DOM binding for TouchList

Categories

(Core :: DOM: Core & HTML, defect)

defect
Not set

Tracking

()

RESOLVED FIXED
mozilla25

People

(Reporter: peterv, Assigned: Ms2ger)

References

Details

Attachments

(1 file, 3 obsolete files)

No description provided.
Attached patch v1 (obsolete) — Splinter Review
Attachment #604528 - Flags: review?(jst)
Attachment #604528 - Flags: review?(jst) → review+
https://hg.mozilla.org/mozilla-central/rev/554ab0a2f470
Status: ASSIGNED → RESOLVED
Closed: 8 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla13
Attachment #604528 - Attachment is patch: true
Depends on: 743325
Backed out because it caused errors in XUL Fennec (bug 743325):
https://hg.mozilla.org/integration/mozilla-inbound/rev/9c0e1f71c15b
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
Target Milestone: mozilla13 → ---
Depends on: 760131
https://hg.mozilla.org/mozilla-central/rev/1554b33212cb
Status: REOPENED → RESOLVED
Closed: 8 years ago7 years ago
Resolution: --- → FIXED
This was backed out in bug 777706. I'm reopening, but I have no idea if that's the right thing to do or not.
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
Attached patch v2 (obsolete) — Splinter Review
Updated to current m-c. If I understand bug 777706 correctly, the issue was that events weren't wrappercached; now that they are, can this land?
Attachment #604528 - Attachment is obsolete: true
Target Milestone: mozilla16 → ---
(In reply to :Ms2ger from comment #8)
> Created attachment 725932 [details] [diff] [review]
> v2

(Note: I haven't tested if this builds or passes tests, and it probably changed enough since last year that it could use a new review.)
Attached patch v2.1 (obsolete) — Splinter Review
This does build.
Attachment #725932 - Attachment is obsolete: true
Duplicate of this bug: 864223
Do you mind if I steal this bug?
Flags: needinfo?(peterv)
No, but don't forget to study.
Flags: needinfo?(peterv)
Depends on: 884748
Attached patch Patch v3Splinter Review
Assignee: peterv → Ms2ger
Attachment #726158 - Attachment is obsolete: true
Status: REOPENED → ASSIGNED
Attachment #764680 - Flags: review?(jst)
Comment on attachment 764680 [details] [diff] [review]
Patch v3

Looks good, r=jst
Attachment #764680 - Flags: review?(jst) → review+
https://hg.mozilla.org/mozilla-central/rev/5f3e6849dfde
Status: ASSIGNED → RESOLVED
Closed: 7 years ago6 years ago
Flags: in-testsuite?
Resolution: --- → FIXED
Target Milestone: --- → mozilla25
Component: DOM → DOM: Core & HTML
You need to log in before you can comment on or make changes to this bug.