All users were logged out of Bugzilla on October 13th, 2018

[SeaMonkey] mochitest-browser-chrome leaks 3 MB (AsyncStatement, AtomImpl, BackstagePass, BodyRule, CalculateFrecencyFunction)

RESOLVED DUPLICATE of bug 603110

Status

P2
major
RESOLVED DUPLICATE of bug 603110
7 years ago
7 years ago

People

(Reporter: sgautherie, Unassigned)

Tracking

({memory-leak})

Trunk
memory-leak

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

7 years ago
http://tinderbox.mozilla.org/showlog.cgi?log=SeaMonkey/1331301917.1331308379.23837.gz
Linux comm-central-trunk debug test mochitest-other on 2012/03/09 06:05:17
{
TEST-UNEXPECTED-FAIL | automationutils.processLeakLog() | leaked 2873707 bytes during test execution
TEST-UNEXPECTED-FAIL | automationutils.processLeakLog() | leaked 1 instance of AsyncStatement with size 48 bytes
TEST-UNEXPECTED-FAIL | automationutils.processLeakLog() | leaked 1875 instances of AtomImpl with size 24 bytes each (45000 bytes total)
TEST-UNEXPECTED-FAIL | automationutils.processLeakLog() | leaked 1 instance of BackstagePass with size 24 bytes
TEST-UNEXPECTED-FAIL | automationutils.processLeakLog() | leaked 40 instances of BodyRule with size 16 bytes each (640 bytes total)
TEST-UNEXPECTED-FAIL | automationutils.processLeakLog() | leaked 1 instance of CalculateFrecencyFunction with size 12 bytes
}

http://tinderbox.mozilla.org/showlog.cgi?log=SeaMonkey/1331344500.1331348873.13634.gz
WINNT 5.2 comm-central-trunk debug test mochitest-other on 2012/03/09 17:55:00
{
TEST-UNEXPECTED-FAIL | automationutils.processLeakLog() | leaked 2949371 bytes during test execution
TEST-UNEXPECTED-FAIL | automationutils.processLeakLog() | leaked 1 instance of AsyncStatement with size 48 bytes
TEST-UNEXPECTED-FAIL | automationutils.processLeakLog() | leaked 1876 instances of AtomImpl with size 24 bytes each (45024 bytes total)
TEST-UNEXPECTED-FAIL | automationutils.processLeakLog() | leaked 1 instance of BackstagePass with size 24 bytes
TEST-UNEXPECTED-FAIL | automationutils.processLeakLog() | leaked 40 instances of BodyRule with size 16 bytes each (640 bytes total)
TEST-UNEXPECTED-FAIL | automationutils.processLeakLog() | leaked 1 instance of CalculateFrecencyFunction with size 12 bytes
}

This looks very similar to FF bug 653080.
We would have a culprit test to find...
(Reporter)

Comment 1

7 years ago
Ftr, -aurora and -beta have different leaks, which we'll just ignore (ftb).
(Reporter)

Comment 2

7 years ago
(In reply to Serge Gautherie (:sgautherie) from comment #1)

Ftr, -aurora/2.9 and -beta/2.8 have different leaks, which we'll just ignore (ftb).
(Reporter)

Updated

7 years ago
No longer depends on: 734148
(Reporter)

Updated

7 years ago
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 603110
You need to log in before you can comment on or make changes to this bug.