Search Function no longer works once the "Stop" command has been invoked

RESOLVED WORKSFORME

Status

()

Core
Layout
RESOLVED WORKSFORME
17 years ago
17 years ago

People

(Reporter: dan.m, Assigned: Nisheeth Ranjan)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

17 years ago
If you go to a web site with a search field, type in a value, and then hit enter
(or click the given search button)...and then click "Stop" to modify your search
term(s), the search field becomes inaccessible.

For example, if you realize only after submitting the search query that you
misspelled something, you cannot click "Stop" and then re-enter the search term,
because the search field itself becomes inaccessible to mouse-clicks. You have
to reload the page entirely to re-enter your search query.
*** Bug 73463 has been marked as a duplicate of this bug. ***

Comment 2

17 years ago
I think that this is actually a failure to "blank" the scren or otherwise start
painting for the next page load.  I suspect that the reason the field becoes
unusable is that the entire page is actually gone, just not repainted yet.  Over
to layout.
Assignee: asa → karnaze
Component: Browser-General → Layout
QA Contact: doronr → petersen
(Reporter)

Comment 3

17 years ago
I believe Asa is correct. Earlier today I was at CDW.com (now using build
2001032613) using their inkjet printer search form. After submitting the form
and getting no results, I clicked the Back button, not realizing there was a
"modify your query link nearby." When I went to click on that link, it was not
accessible. Nor was the search field at the top of the web page (which is on
every page).

Comment 4

17 years ago
With the April 3 Mac build, I'm not able to reproduce this issue. Tested under
Mac OS 9.1. Reporter, please download the latest mac build and try this again.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → WORKSFORME
(Reporter)

Comment 5

17 years ago
Chris, downloaded build 2001040309...same behavior occurs under the
circumstances mentioned above. No system alterations since last report....

Comment 6

17 years ago
I was using 2001040309 previously, but I can now see a problem with form
elements on this page (www.cdw.com) If you go to the product finder url,
http://www.cdw.com/shop/tools/productfinder/finder.asp?Folder=IP
Status: RESOLVED → UNCONFIRMED
Resolution: WORKSFORME → ---

Comment 7

17 years ago
Confirming bug
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 8

17 years ago
If you click on the Maximum Price field to apply focus, the cursor appears above
next to the "Ink Jet printers" image.

Comment 9

17 years ago
Reproduces on  Windows ME (2001040304).
OS: Mac System 9.x → All
Hardware: Macintosh → All

Comment 10

17 years ago
Reassigning to saari.
Assignee: karnaze → saari

Comment 11

17 years ago
Reassigning to Nisheeth, who I think has dealt with loading issues in the pres 
shell and elsewhere.
Assignee: saari → nisheeth

Comment 12

17 years ago
*** Bug 74267 has been marked as a duplicate of this bug. ***
hyatt checked in some paint changes, and I can't reproduce this on a build from
yesterday. Marking worksforme.
Status: NEW → RESOLVED
Last Resolved: 17 years ago17 years ago
Resolution: --- → WORKSFORME
(Reporter)

Comment 14

17 years ago
Using Mac Mozilla .9, this feature now seems to work for me as well.
You need to log in before you can comment on or make changes to this bug.