Crash in mozHunspell::SetDictionary @ HashMgr::load_tables

RESOLVED WORKSFORME

Status

()

--
critical
RESOLVED WORKSFORME
7 years ago
2 years ago

People

(Reporter: Swarnava, Unassigned)

Tracking

({crash})

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [needs STR], crash signature)

(Reporter)

Description

7 years ago
This bug was filed from the Socorro interface and is 
report bp-363cdf5f-21a3-47d7-af7e-ebb662120310 .
============================================================= 

this crash is happen by Firebug 1.9.1 and Firefox 11 beta 7. I cant reproduce this with Firefox 11 beta 5 or 6
(Reporter)

Updated

7 years ago
Summary: Firefox cause by Firebug - crash _chkstk → Firefox crash cause by Firebug - crash _chkstk

Comment 1

7 years ago
This signature exists in other versions at a low volume:
https://crash-stats.mozilla.com/report/list?signature=_chkstk+|+HashMgr%3A%3Aload_tables%28char+const*%2C+char+const*%29

Can you provide steps to reproduce in Fx 11 Bêta 7?
(Reporter)

Comment 2

7 years ago
(In reply to Scoobidiver from comment #1)
 
> Can you provide steps to reproduce in Fx 11 Bêta 7?

Upgraded ff to 11b7 from 11b6, and installed right after Firebug. Than I opened a Youtube page and/or Echofon and firefox crashed
(Reporter)

Comment 3

7 years ago
i install Firebug 1.10a5>Uninstalled>Install Firebug 1.9.1 but i cant reproduce this crash anymore
Component: Extension Compatibility → Untriaged
QA Contact: extension.compatibility → untriaged
Summary: Firefox crash cause by Firebug - crash _chkstk → Firefox crash - crash _chkstk

Comment 4

7 years ago
It happens mainly on Windows XP.

The stack looks like:
Frame 	Module 	Signature [Expand] 	Source
0 	xul.dll 	_chkstk 	chkstk.asm:99
1 	xul.dll 	HashMgr::load_tables 	extensions/spellcheck/hunspell/src/hashmgr.cpp:518
2 	xul.dll 	HashMgr::HashMgr 	extensions/spellcheck/hunspell/src/hashmgr.cpp:89
3 	xul.dll 	Hunspell::Hunspell 	extensions/spellcheck/hunspell/src/hunspell.cpp:79
4 	xul.dll 	mozHunspell::SetDictionary 	extensions/spellcheck/hunspell/src/mozHunspell.cpp:220
5 	xul.dll 	PromiseFlatString 	obj-firefox/dist/include/nsTPromiseFlatString.h:134
6 	xul.dll 	mozSpellChecker::SetCurrentDictionary 	extensions/spellcheck/src/mozSpellChecker.cpp:385
Crash Signature: [@ _chkstk | HashMgr::load_tables(char const*, char const*)] → [@ _chkstk | HashMgr::load_tables(char const*, char const*)] [@ _alloca_probe | HashMgr::load_tables(char const*, char const*)]
Component: Untriaged → Spelling checker
OS: Windows NT → Windows XP
Product: Firefox → Core
QA Contact: untriaged → spelling-checker
Summary: Firefox crash - crash _chkstk → Cras in mozHunspell::SetDictionary @ HashMgr::load_tables
(Reporter)

Updated

7 years ago
Summary: Cras in mozHunspell::SetDictionary @ HashMgr::load_tables → Crash in mozHunspell::SetDictionary @ HashMgr::load_tables

Comment 5

7 years ago
I installed the Italian dictionary and tried to reproduce this but I was not successful.  We need steps to reproduce here...
Whiteboard: [needs STR]
(Reporter)

Comment 6

7 years ago
Even i cant understand why this is happening..at first i thought Firebug causing the issue but after un and reinstall the crash doesnot happen anymore

Comment 7

7 years ago
FWIW, the crash is happening when the spell checker engine tries to load a dictionary.  You seem to have the Italian dictionary installed, which is why I suspected that there is something wrong with that dictionary, but looking at the other crash reports it seems like this happens to people with different dictionaries, which makes diagnosing this much harder.

I would be extremely surprised if Firebug is a factor here.

Updated

3 years ago
Crash Signature: [@ _chkstk | HashMgr::load_tables(char const*, char const*)] [@ _alloca_probe | HashMgr::load_tables(char const*, char const*)] → [@ _chkstk | HashMgr::load_tables(char const*, char const*)] [@ _alloca_probe | HashMgr::load_tables(char const*, char const*)] [@ _chkstk | HashMgr::load_tables] [@ _alloca_probe | HashMgr::load_tables]

Comment 8

2 years ago
In 6 months only a version 31, 24, and 17 crash. So WFM
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.