If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

XUL dialogs are appearing full screen

VERIFIED DUPLICATE of bug 72530

Status

()

Core
XUL
VERIFIED DUPLICATE of bug 72530
17 years ago
17 years ago

People

(Reporter: kinmoz, Assigned: Joe Hewitt (gone))

Tracking

Trunk
x86
Windows NT
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

17 years ago
In my 03/25/01 Win32 Debug Trunk build, using the Modern skin, I'm seeing XUL 
dialogs occassionally show up full screen. When this happens, there is no way 
for me to get rid of the dialog since the borders of the dialog (including the 
title bar) are off screen. Also I don't see any widgets in the window, it's just 
a big blank blue dialog window.

In the console I see the following:

    HLine Properties startup...
    Done with INIT
    WEBSHELL+ = 8
    window moved to offscreen position
    weird status return -2142109690

I'm seeing this in various parts of the app (browser, mail, etc.), but it seems 
that I can consistently reproduce this in composer with the following steps:

  1. Bring up a blank composer.
  2. Press the HLine button on the toolbar to insert an HRule.
  3. Right click on the HRule and bring up the Horizontal Line Properties 
dialog.
  4. Enter some ridiculous number like 233333 for the height and h it the ok 
button.

You should now get a window that fills the entire screen.
(Reporter)

Comment 1

17 years ago
Hmmmm seems to be a Modern skin problem, since I can't reproduce this in 
Classic. cmanske says this should go to hewitt.
Assignee: danm → hewitt

Comment 2

17 years ago
Hmmm. I can't reproduce in either modern or classic
(Assignee)

Comment 3

17 years ago
I am only able to duplicate this AFTER a theme switch.  It will happen in both
themes.  This is definitely not a Theme-css related problem.  I'm really not
sure who this bug belongs to.
Assignee: hewitt → trudelle

Comment 4

17 years ago
*** Bug 73484 has been marked as a duplicate of this bug. ***

Comment 5

17 years ago
Ok, if not themes, then this kind of window size problem has been seen before
and danm fixed those issues. I'd say give it to him, but hyatt may also have
some insight.

Comment 6

17 years ago
->danm
Assignee: trudelle → danm

Comment 7

17 years ago
modern theme chrome directory is missing chrome://global/skin/dialogOverlay.css, 
chrome://global/skin/alert-icon.gif and chrome://global/skin/message-icon.gif. 
Supply them and the alert comes up properly.
Assignee: danm → hewitt
(Assignee)

Comment 8

17 years ago

*** This bug has been marked as a duplicate of 72530 ***
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → DUPLICATE

Comment 9

17 years ago
verified dupe
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.