Last Comment Bug 734677 - High memory leak for playback photo album vk.com (due to Page Speed 1.12.0.2 add-on)
: High memory leak for playback photo album vk.com (due to Page Speed 1.12.0.2 ...
Status: RESOLVED FIXED
[MemShrink:P3]
:
Product: Core
Classification: Components
Component: Find Backend (show other bugs)
: 13 Branch
: All All
: -- normal (vote)
: ---
Assigned To: Nobody; OK to take it and work on it
:
:
Mentors:
http://vk.com/album-21239875_154053113
Depends on:
Blocks: LeakyAddons
  Show dependency treegraph
 
Reported: 2012-03-10 12:18 PST by adminnu
Modified: 2012-03-26 11:40 PDT (History)
8 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
memory-high.txt (4.10 KB, text/plain)
2012-03-10 12:18 PST, adminnu
no flags Details
mimimize.txt (5.61 KB, text/plain)
2012-03-10 12:19 PST, adminnu
no flags Details
memory-high-verbose.txt (165.19 KB, text/plain)
2012-03-10 12:19 PST, adminnu
no flags Details
mimimize-verbose.txt (160.82 KB, text/plain)
2012-03-10 12:20 PST, adminnu
no flags Details

Description adminnu 2012-03-10 12:18:12 PST
Created attachment 604674 [details]
memory-high.txt

User Agent: Mozilla/5.0 (Windows NT 6.1; rv:13.0) Gecko/20120310 Firefox/13.0a1
Build ID: 20120310031046

Steps to reproduce:

Carried prosomotr photos in album http://vk.com/album-21239875_154053113



Actual results:

After reviewing about 150 pictures began to hang the browser, and possibly earlier. Checked the (about:memory):
1,609.22 MB (100.0%) -- explicit

Click minimize memory usage drops to normal state:
612.07 MB (100.0%) -- explicit

Minimization of memory starts, but a sharp memory blockage does not save crash.
Comment 1 adminnu 2012-03-10 12:19:14 PST
Created attachment 604675 [details]
mimimize.txt
Comment 2 adminnu 2012-03-10 12:19:53 PST
Created attachment 604676 [details]
memory-high-verbose.txt
Comment 3 adminnu 2012-03-10 12:20:34 PST
Created attachment 604677 [details]
mimimize-verbose.txt
Comment 4 adminnu 2012-03-10 12:30:40 PST
A critical priority is raised this issue because vk.com is one of the most visited resources of the world, and this bug may appear on a variety of other resources.
Comment 5 adminnu 2012-03-10 12:52:07 PST
If you minimize prodolzhet viewing photos, scanned for 3-6 pool at once increased from 600 to 1600 mb. That is, for some 10-20 seconds to 1 GB.
Comment 6 adminnu 2012-03-10 13:44:36 PST
http://youtu.be/OPP2vUA81d8

Posted by video which details can be seen that as happening.
Prior to 2:56 when viewing photos, memory up to 450 MB. up to 1.7 GB. At this point the browser to hang nachivaet and photos are no longer scrolled.
Then, 3:14 I turn to the tab about: memory, probably triggered an automatic minimization of the memory has plummeted to 454 mb.
Then I switch to the tab with the picture begins to rise sharply, and memory, at 3:40, she was already back up to 1.7 GB.
Then I go back to about: memory and do the minimization of memory, it falls to 450 mb. And so a few times.
Hopefully this will greatly help solve the problem. Thank you.
Comment 7 adminnu 2012-03-12 23:49:28 PDT
Today, the work performed is the same PC, i7 3.2GHz (4 core), 8MB RAM, win64.
The problem was repeated in a tee tee.

However on this pc in safe mode, the problem disappeared. And clean all the time. Did not rise above 300MB.
At random find the culprit Page Speed ​​1.12.0.2.
Comment 8 Justin Lebar (not reading bugmail) 2012-03-13 13:55:39 PDT
> At random find the culprit Page Speed ​​1.12.0.2.

To be clear: Do you mean that the problem occurs only with this add-on enabled?
Comment 9 Justin Lebar (not reading bugmail) 2012-03-13 13:58:21 PDT
I guess the relevant add-on is a Firebug extension?

http://getfirebug.com/wiki/index.php/Firebug_Extensions#Page_Speed
http://code.google.com/speed/page-speed/
Comment 10 Jet Villegas (:jet) 2012-03-13 14:11:51 PDT
P3 per Memshrink.
Comment 11 Justin Lebar (not reading bugmail) 2012-03-13 14:23:29 PDT
I filed http://code.google.com/p/page-speed/issues/detail?id=657
Comment 12 adminnu 2012-03-14 01:58:28 PDT
Yes, if you disable add-on, the memory cleaned up to a maximum addition of memory is not clear privyshat 100-150MB. That is much better.
Please check out a similar problem on several PCs.
As I understand it, is required to solve the following problem:
1) Why are page-speed memory usage when not active, and page speed firebug and firefox allocates memory for it;
2) There may be a mechanism to optimize the hole;
3) If you can not fix this hole from firefox, should be corrected in page speed or firebug;
With regard to the priority of agree with the user level Sub supplement sharply reduced, but there may be similar problems with other additions.
Comment 13 Bryan McQuade 2012-03-19 07:49:40 PDT
Thanks, we've isolated the issue and come up with a fix, which we'll roll out next week. This was somewhat of a corner case issues specific to photo gallery pages like this one. Nonetheless we'll be rolling out a fix shortly. Please see http://code.google.com/p/page-speed/issues/detail?id=657 for more details.
Comment 14 Bryan McQuade 2012-03-19 12:06:09 PDT
You can find an updated version of Page Speed with the memory fix here: https://dl.google.com/page-speed/1.12.0.3/page-speed.xpi
Comment 15 Jorge Villalobos [:jorgev] 2012-03-21 12:45:40 PDT
adminnu, can you please verify this new version fixes the leak?

Thanks.
Comment 16 adminnu 2012-03-21 23:58:41 PDT
Yes on version 1.12.0.3, the memory maximum is increased to the cleaning, the 100-200 mb. We can assume the problem solved. If additional action by the mozilla will not run, the bug can be closed.

Note You need to log in before you can comment on or make changes to this bug.