Last Comment Bug 734701 - Intermittent mochitest-browser-chrome failure browser/components/downloads/test/browser/browser_delete_key_removes.js | The download was properly removed - Got 6, expected 5 and a few more after it
: Intermittent mochitest-browser-chrome failure browser/components/downloads/te...
Status: RESOLVED FIXED
: intermittent-failure
Product: Firefox
Classification: Client Software
Component: General (show other bugs)
: Trunk
: All All
: -- normal (vote)
: ---
Assigned To: :Paolo Amadini
:
:
Mentors:
: 734702 (view as bug list)
Depends on:
Blocks: 438871 726444
  Show dependency treegraph
 
Reported: 2012-03-10 18:50 PST by Ryan VanderMeulen [:RyanVM]
Modified: 2012-11-25 19:31 PST (History)
4 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Focus the first element of the downloads list explicitly (1.68 KB, patch)
2012-03-11 06:58 PDT, :Paolo Amadini
mak77: review+
Details | Diff | Splinter Review

Description Ryan VanderMeulen [:RyanVM] 2012-03-10 18:50:29 PST
I guess bug 726444 comment 42 saw this coming...
https://tbpl.mozilla.org/php/getParsedLog.php?id=9981375&tree=Mozilla-Inbound

TEST-START | chrome://mochitests/content/browser/browser/components/downloads/test/browser/browser_delete_key_removes.js
TEST-PASS | chrome://mochitests/content/browser/browser/components/downloads/test/browser/browser_delete_key_removes.js | The database and the number of downloads display matches
TEST-UNEXPECTED-FAIL | chrome://mochitests/content/browser/browser/components/downloads/test/browser/browser_delete_key_removes.js | The download was properly removed - Got 6, expected 5
Stack trace:
    JS frame :: chrome://mochikit/content/browser-test.js :: test_is :: line 446
    JS frame :: chrome://mochitests/content/browser/browser/components/downloads/test/browser/browser_delete_key_removes.js :: <TOP_LEVEL> :: line 70

TEST-UNEXPECTED-FAIL | chrome://mochitests/content/browser/browser/components/downloads/test/browser/browser_delete_key_removes.js | The download was properly removed - Got 6, expected 4
Stack trace:
    JS frame :: chrome://mochikit/content/browser-test.js :: test_is :: line 446
    JS frame :: chrome://mochitests/content/browser/browser/components/downloads/test/browser/browser_delete_key_removes.js :: <TOP_LEVEL> :: line 70

TEST-UNEXPECTED-FAIL | chrome://mochitests/content/browser/browser/components/downloads/test/browser/browser_delete_key_removes.js | The download was properly removed - Got 6, expected 3
Stack trace:
    JS frame :: chrome://mochikit/content/browser-test.js :: test_is :: line 446
    JS frame :: chrome://mochitests/content/browser/browser/components/downloads/test/browser/browser_delete_key_removes.js :: <TOP_LEVEL> :: line 70

TEST-UNEXPECTED-FAIL | chrome://mochitests/content/browser/browser/components/downloads/test/browser/browser_delete_key_removes.js | The download was properly removed - Got 6, expected 2
Stack trace:
    JS frame :: chrome://mochikit/content/browser-test.js :: test_is :: line 446
    JS frame :: chrome://mochitests/content/browser/browser/components/downloads/test/browser/browser_delete_key_removes.js :: <TOP_LEVEL> :: line 70

TEST-UNEXPECTED-FAIL | chrome://mochitests/content/browser/browser/components/downloads/test/browser/browser_delete_key_removes.js | The download was properly removed - Got 5, expected 1
Stack trace:
    JS frame :: chrome://mochikit/content/browser-test.js :: test_is :: line 446
    JS frame :: chrome://mochitests/content/browser/browser/components/downloads/test/browser/browser_delete_key_removes.js :: <TOP_LEVEL> :: line 70

TEST-UNEXPECTED-FAIL | chrome://mochitests/content/browser/browser/components/downloads/test/browser/browser_delete_key_removes.js | The download was properly removed - Got 4, expected 0
Stack trace:
    JS frame :: chrome://mochikit/content/browser-test.js :: test_is :: line 446
    JS frame :: chrome://mochitests/content/browser/browser/components/downloads/test/browser/browser_delete_key_removes.js :: <TOP_LEVEL> :: line 70

INFO TEST-END | chrome://mochitests/content/browser/browser/components/downloads/test/browser/browser_delete_key_removes.js | finished in 1407ms
Comment 1 Ryan VanderMeulen [:RyanVM] 2012-03-10 18:52:47 PST
*** Bug 734702 has been marked as a duplicate of this bug. ***
Comment 2 Treeherder Robot 2012-03-10 22:19:54 PST
philor
https://tbpl.mozilla.org/php/getParsedLog.php?id=9983353&tree=Mozilla-Inbound
Rev3 WINNT 5.1 mozilla-inbound pgo test mochitest-other on 2012-03-10 21:24:20

TEST-UNEXPECTED-FAIL | chrome://mochitests/content/browser/browser/components/downloads/test/browser/browser_delete_key_removes.js | The download was properly removed - Got 6, expected 5
TEST-UNEXPECTED-FAIL | chrome://mochitests/content/browser/browser/components/downloads/test/browser/browser_delete_key_removes.js | The download was properly removed - Got 5, expected 4
TEST-UNEXPECTED-FAIL | chrome://mochitests/content/browser/browser/components/downloads/test/browser/browser_delete_key_removes.js | The download was properly removed - Got 4, expected 3
TEST-UNEXPECTED-FAIL | chrome://mochitests/content/browser/browser/components/downloads/test/browser/browser_delete_key_removes.js | The download was properly removed - Got 3, expected 2
TEST-UNEXPECTED-FAIL | chrome://mochitests/content/browser/browser/components/downloads/test/browser/browser_delete_key_removes.js | The download was properly removed - Got 2, expected 1
TEST-UNEXPECTED-FAIL | chrome://mochitests/content/browser/browser/components/downloads/test/browser/browser_delete_key_removes.js | The download was properly removed - Got 1, expected 0
Comment 3 :Paolo Amadini 2012-03-10 23:26:57 PST
(In reply to Ryan VanderMeulen from comment #0)
> I guess bug 726444 comment 42 saw this coming...

Actually we fixed that, it was a different case and deterministic on Mac only.

This intermittent failure is probably due to the Downloads Panel getting focus in
a delayed manner in some cases. A call to waitForFocus might fix it, I will make a
patch later today.
Comment 4 Treeherder Robot 2012-03-11 00:46:57 PST
Ms2ger%gmail.com
https://tbpl.mozilla.org/php/getParsedLog.php?id=9983782&tree=Mozilla-Inbound
Rev3 WINNT 6.1 mozilla-inbound pgo test mochitest-other on 2012-03-11 00:03:19

TEST-UNEXPECTED-FAIL | chrome://mochitests/content/browser/browser/components/downloads/test/browser/browser_delete_key_removes.js | The download was properly removed - Got 6, expected 5
TEST-UNEXPECTED-FAIL | chrome://mochitests/content/browser/browser/components/downloads/test/browser/browser_delete_key_removes.js | The download was properly removed - Got 6, expected 4
TEST-UNEXPECTED-FAIL | chrome://mochitests/content/browser/browser/components/downloads/test/browser/browser_delete_key_removes.js | The download was properly removed - Got 5, expected 3
TEST-UNEXPECTED-FAIL | chrome://mochitests/content/browser/browser/components/downloads/test/browser/browser_delete_key_removes.js | The download was properly removed - Got 4, expected 2
TEST-UNEXPECTED-FAIL | chrome://mochitests/content/browser/browser/components/downloads/test/browser/browser_delete_key_removes.js | The download was properly removed - Got 3, expected 1
TEST-UNEXPECTED-FAIL | chrome://mochitests/content/browser/browser/components/downloads/test/browser/browser_delete_key_removes.js | The download was properly removed - Got 2, expected 0
Comment 5 Treeherder Robot 2012-03-11 00:54:38 PST
Ms2ger%gmail.com
https://tbpl.mozilla.org/php/getParsedLog.php?id=9983769&tree=Mozilla-Inbound
Rev3 WINNT 5.1 mozilla-inbound pgo test mochitest-other on 2012-03-11 00:03:20

TEST-UNEXPECTED-FAIL | chrome://mochitests/content/browser/browser/components/downloads/test/browser/browser_delete_key_removes.js | The download was properly removed - Got 6, expected 5
TEST-UNEXPECTED-FAIL | chrome://mochitests/content/browser/browser/components/downloads/test/browser/browser_delete_key_removes.js | The download was properly removed - Got 6, expected 4
TEST-UNEXPECTED-FAIL | chrome://mochitests/content/browser/browser/components/downloads/test/browser/browser_delete_key_removes.js | The download was properly removed - Got 5, expected 3
TEST-UNEXPECTED-FAIL | chrome://mochitests/content/browser/browser/components/downloads/test/browser/browser_delete_key_removes.js | The download was properly removed - Got 4, expected 2
TEST-UNEXPECTED-FAIL | chrome://mochitests/content/browser/browser/components/downloads/test/browser/browser_delete_key_removes.js | The download was properly removed - Got 3, expected 1
TEST-UNEXPECTED-FAIL | chrome://mochitests/content/browser/browser/components/downloads/test/browser/browser_delete_key_removes.js | The download was properly removed - Got 2, expected 0
Comment 6 Treeherder Robot 2012-03-11 05:45:25 PDT
Ms2ger%gmail.com
https://tbpl.mozilla.org/php/getParsedLog.php?id=9985427&tree=Mozilla-Inbound
Rev3 Fedora 12x64 mozilla-inbound pgo test mochitest-other on 2012-03-11 04:49:38

TEST-UNEXPECTED-FAIL | chrome://mochitests/content/browser/browser/base/content/test/browser_sanitize-timespans.js | Pretend visit to today.com should still exist
TEST-UNEXPECTED-FAIL | chrome://mochitests/content/browser/browser/base/content/test/browser_sanitize-timespans.js | today form entry should still exist
TEST-UNEXPECTED-FAIL | chrome://mochitests/content/browser/browser/base/content/test/browser_sanitize-timespans.js | 'Today' download should still be present
TEST-UNEXPECTED-FAIL | chrome://mochitests/content/browser/browser/components/downloads/test/browser/browser_delete_key_removes.js | The download was properly removed - Got 6, expected 5
TEST-UNEXPECTED-FAIL | chrome://mochitests/content/browser/browser/components/downloads/test/browser/browser_delete_key_removes.js | The download was properly removed - Got 5, expected 4
TEST-UNEXPECTED-FAIL | chrome://mochitests/content/browser/browser/components/downloads/test/browser/browser_delete_key_removes.js | The download was properly removed - Got 4, expected 3
TEST-UNEXPECTED-FAIL | chrome://mochitests/content/browser/browser/components/downloads/test/browser/browser_delete_key_removes.js | The download was properly removed - Got 3, expected 2
TEST-UNEXPECTED-FAIL | chrome://mochitests/content/browser/browser/components/downloads/test/browser/browser_delete_key_removes.js | The download was properly removed - Got 2, expected 1
TEST-UNEXPECTED-FAIL | chrome://mochitests/content/browser/browser/components/downloads/test/browser/browser_delete_key_removes.js | The download was properly removed - Got 1, expected 0
Comment 7 Treeherder Robot 2012-03-11 06:17:34 PDT
Ms2ger%gmail.com
https://tbpl.mozilla.org/php/getParsedLog.php?id=9986002&tree=Mozilla-Inbound
Rev3 WINNT 6.1 mozilla-inbound pgo test mochitest-other on 2012-03-11 05:28:19

TEST-UNEXPECTED-FAIL | chrome://mochitests/content/browser/browser/components/downloads/test/browser/browser_delete_key_removes.js | The download was properly removed - Got 6, expected 5
TEST-UNEXPECTED-FAIL | chrome://mochitests/content/browser/browser/components/downloads/test/browser/browser_delete_key_removes.js | The download was properly removed - Got 5, expected 4
TEST-UNEXPECTED-FAIL | chrome://mochitests/content/browser/browser/components/downloads/test/browser/browser_delete_key_removes.js | The download was properly removed - Got 4, expected 3
TEST-UNEXPECTED-FAIL | chrome://mochitests/content/browser/browser/components/downloads/test/browser/browser_delete_key_removes.js | The download was properly removed - Got 3, expected 2
TEST-UNEXPECTED-FAIL | chrome://mochitests/content/browser/browser/components/downloads/test/browser/browser_delete_key_removes.js | The download was properly removed - Got 2, expected 1
TEST-UNEXPECTED-FAIL | chrome://mochitests/content/browser/browser/components/downloads/test/browser/browser_delete_key_removes.js | The download was properly removed - Got 1, expected 0
Comment 8 :Paolo Amadini 2012-03-11 06:58:54 PDT
Created attachment 604771 [details] [diff] [review]
Focus the first element of the downloads list explicitly

This might fix the issue, should be verified in the field. I executed the test
locally and it still works (but, locally, it worked before as well).

I've requested review to Marco, but if someone else can review the patch sooner
and try it in the tree, it's also better.
Comment 9 Treeherder Robot 2012-03-11 08:57:31 PDT
Ms2ger%gmail.com
https://tbpl.mozilla.org/php/getParsedLog.php?id=9986414&tree=Mozilla-Inbound
Rev3 WINNT 5.1 mozilla-inbound pgo test mochitest-other on 2012-03-11 06:47:05

TEST-UNEXPECTED-FAIL | chrome://mochitests/content/browser/browser/components/downloads/test/browser/browser_delete_key_removes.js | The download was properly removed - Got 6, expected 5
TEST-UNEXPECTED-FAIL | chrome://mochitests/content/browser/browser/components/downloads/test/browser/browser_delete_key_removes.js | The download was properly removed - Got 6, expected 4
TEST-UNEXPECTED-FAIL | chrome://mochitests/content/browser/browser/components/downloads/test/browser/browser_delete_key_removes.js | The download was properly removed - Got 6, expected 3
TEST-UNEXPECTED-FAIL | chrome://mochitests/content/browser/browser/components/downloads/test/browser/browser_delete_key_removes.js | The download was properly removed - Got 5, expected 2
TEST-UNEXPECTED-FAIL | chrome://mochitests/content/browser/browser/components/downloads/test/browser/browser_delete_key_removes.js | The download was properly removed - Got 4, expected 1
TEST-UNEXPECTED-FAIL | chrome://mochitests/content/browser/browser/components/downloads/test/browser/browser_delete_key_removes.js | The download was properly removed - Got 3, expected 0
Comment 10 Treeherder Robot 2012-03-11 15:02:51 PDT
philor
https://tbpl.mozilla.org/php/getParsedLog.php?id=9989467&tree=Mozilla-Inbound
Rev3 WINNT 5.1 mozilla-inbound pgo test mochitest-other on 2012-03-11 14:26:21

TEST-UNEXPECTED-FAIL | chrome://mochitests/content/browser/browser/components/downloads/test/browser/browser_delete_key_removes.js | The download was properly removed - Got 6, expected 5
TEST-UNEXPECTED-FAIL | chrome://mochitests/content/browser/browser/components/downloads/test/browser/browser_delete_key_removes.js | The download was properly removed - Got 6, expected 4
TEST-UNEXPECTED-FAIL | chrome://mochitests/content/browser/browser/components/downloads/test/browser/browser_delete_key_removes.js | The download was properly removed - Got 6, expected 3
TEST-UNEXPECTED-FAIL | chrome://mochitests/content/browser/browser/components/downloads/test/browser/browser_delete_key_removes.js | The download was properly removed - Got 5, expected 2
TEST-UNEXPECTED-FAIL | chrome://mochitests/content/browser/browser/components/downloads/test/browser/browser_delete_key_removes.js | The download was properly removed - Got 4, expected 1
TEST-UNEXPECTED-FAIL | chrome://mochitests/content/browser/browser/components/downloads/test/browser/browser_delete_key_removes.js | The download was properly removed - Got 3, expected 0
Comment 11 Ryan VanderMeulen [:RyanVM] 2012-03-11 15:05:14 PDT
Interesting that it only seems to happen on pgo builds.
Comment 12 Marco Bonardo [::mak] 2012-03-12 12:46:51 PDT
Comment on attachment 604771 [details] [diff] [review]
Focus the first element of the downloads list explicitly

Review of attachment 604771 [details] [diff] [review]:
-----------------------------------------------------------------

may be fine, assuming there is no expected delay on setting the focus after each delete. Btw it's worth a try.
Comment 13 :Paolo Amadini 2012-04-20 09:27:27 PDT
This was included in the final patch, but worked only in in some cases. For now,
we have removed the test, we will add it again later.

Note You need to log in before you can comment on or make changes to this bug.