Closed Bug 734723 Opened 9 years ago Closed 8 years ago

Printing http://www.mozilla.org/en-US/firefox/fx/ is missing many parts of the page (color, images, etc)

Categories

(www.mozilla.org :: General, defect)

x86_64
Windows 7
defect
Not set
normal

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 567839

People

(Reporter: jsmith, Unassigned)

Details

Attachments

(1 file)

Steps:

1. Go to http://www.mozilla.org/en-US/firefox/fx/
2. Select to print this page
3. Confirm to print this page

Expected:

The page as shown on the webpage prints out on a single sheet of paper.

Actual:

See attached PDF (printed to PDF using PDFCreator). This is the page I see printed. Many parts of the page are missing (e.g. color, alignment, images).
Version: 13 Branch → 11 Branch
Seen in cases specifically if I try to print to PDF using PDFCreator print to OneNote using "Send to OneNote." Both the OneNote version of the print out and the PDFCreator version of the print out represent the attachment above.
color, alignment, images are specified in CSS with media="screen" (See <link rel="stylesheet" href="/style/covehead/home-fx.css" media="screen" />).
So, I think this is correct behavior for print media.
If this is correct behavior, then this may be a Mozilla-website problem, not a Firefox problem. I noticed a similar issue with the careers page (missing color, alignment, images). Marking as qa-wanted and cc-ing Stephen Donner (WebQA lead). Stephen - Is this a known issue with some of the Mozilla websites? Are there bugs filed on this "printing" issue? If not, where should these bugs (such as this one being moved to) be filed?
Whiteboard: qa-wanted
(In reply to Jason Smith from comment #3)
> If this is correct behavior, then this may be a Mozilla-website problem, not
> a Firefox problem. I noticed a similar issue with the careers page (missing
> color, alignment, images). Marking as qa-wanted and cc-ing Stephen Donner
> (WebQA lead). Stephen - Is this a known issue with some of the Mozilla
> websites? Are there bugs filed on this "printing" issue? If not, where
> should these bugs (such as this one being moved to) be filed?

Raymond might know better for Mozilla.org/firefox, but it brings up a good point about all our sites in general.  I will ask the Web Production team if there's a standard level of support/some sort of checklist in development, for printing our websites.  We generally don't test that, but maybe should.

If you want the Mozilla.org/firefox team to look at it, that goes in Product: Websites, Component: www.mozilla.org/firefox
Component: General → www.mozilla.org/firefox
Product: Firefox → Websites
QA Contact: general → www-mozilla-com
Version: 11 Branch → unspecified
This a a website bug as the same thing happens in other browsers( ie Chrome and Safari). Ccing James ans Steven
Whiteboard: qa-wanted
Jason, thanks for noting this. We're actually solving this with print-friendly style sheets in the mozilla.org and mozilla.org/firefox redesign (this will launch on March 29). 

For the mozilla.org and mozilla.org/firefox websites this will be baked into the experience. Closing as resolved/worksforme no worries though a fix is in the works, just not for the current sites as they exist. Please email me at cbrodigan@mozilla.com if you have questions about the redesign.
Status: NEW → RESOLVED
Closed: 9 years ago
Resolution: --- → WORKSFORME
Any reason we couldn't leave this open so this can be tested and verified, post-redesign?  Or duped to the implementation bug, if one exists?
(In reply to Stephen Donner [:stephend] from comment #7)
> Any reason we couldn't leave this open so this can be tested and verified,
> post-redesign?  Or duped to the implementation bug, if one exists?

This isn't WFM, per https://bugzilla.mozilla.org/page.cgi?id=fields.html#resolution.  Leaving open so we can re-evaluate this when we have a technical solution we can test and verify.
Status: RESOLVED → REOPENED
Resolution: WORKSFORME → ---
Sorry Stephen, I hate "wontfix" it sounds so depressing.

- /fx is being refreshed before being ported to Bedrock, Bug 733828 (in Q2 it is going through an extensive overhaul, so we are putting moderate resources to work at this phase)

- Bug 730809 is open for ongoing refactoring to templates on Bedrock

- We will no longer make changes to mozilla.org and mozilla.org/firefox PHP sites as they exist today, starting tomorrow, due to resource constraints we will only work on Bedrock

Lastly, print styles are a nice to have, for the /firefox product site, we have to put them as a lower priority. 

For blog.mozilla.com and the Blogzilla theme, we've built them right into the experience to make the most of editorial content for offline reading.

I've moved to Future, so this can stay on the radar, but hopefully the bugs mentioned here and the approach we're taking make a good case for closing we're managing a higher volume of bugs and transitioning across components.

Integrating print as part of a frontend dev and QA checklist on all new pages and updated pages would be awesome!
Component: www.mozilla.org/firefox → www.mozilla.org
Component: www.mozilla.org → General
Product: Websites → www.mozilla.org
Status: REOPENED → RESOLVED
Closed: 9 years ago8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 567839
You need to log in before you can comment on or make changes to this bug.