ASSERTION: This should never be 0!

RESOLVED DUPLICATE of bug 672667

Status

()

RESOLVED DUPLICATE of bug 672667
7 years ago
7 years ago

People

(Reporter: mrbkap, Unassigned)

Tracking

({assertion})

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

Created attachment 604792 [details]
The C++ and JS stacks

Steps to reproduce:
 * Compile B2G in debug mode.
 * Clone the gaia repository at <https://github.com/andreasgal/gaia>.
 * Follow the instructions at <https://wiki.mozilla.org/Gaia/Hacking#Desktop> to launch B2G.
 * Dismiss the lock screen and select the "gmail app"
 * Click in one of the text boxes

Somewhat complicating things (it would be good to know this happens on a vanilla trunk) is that my tip is 6e10f2a2fc40404389dd0afc07a9571cbb90a35d in <https://github.com/cgjones/mozilla-central/>. My gaia repo is at b8ba437ea0d14f77a3c3af73ae88bf988ed14aa6.

Actual results:

###!!! ASSERTION: This should never be 0!: 'depth', file /Users/mrbkap/work/ril/mozilla/dom/indexedDB/IDBTransaction.cpp, line 151

Expected results:

No assertion

The attachment is the C++ stack and the JS stack. I haven't checked yet whether this affect every text box or if it's specifically related to the gmail app.
This seems to happen any time the keyboard pops up.
I bet this is the same underlying issue as bug 672667.
I believe it.
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 672667
You need to log in before you can comment on or make changes to this bug.