If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Whine emails show as empty due body misformat

RESOLVED WORKSFORME

Status

()

Bugzilla
Whining
RESOLVED WORKSFORME
6 years ago
5 years ago

People

(Reporter: nick4u, Unassigned)

Tracking

Details

Attachments

(1 attachment)

(Reporter)

Description

6 years ago
Created attachment 604862 [details]
[Bugzilla] Bugi do SWD-ST z ostatniej doby.eml

User Agent: Mozilla/5.0 (Windows NT 6.1) AppleWebKit/535.11 (KHTML, like Gecko) Chrome/17.0.963.78 Safari/535.11

Steps to reproduce:

I have added new event in bugzilla whining. Report is send by email but ...


Actual results:

email displays as empty (outlook, thunderbid)



Expected results:

obviously this is not right but ... after little investigating I have found that when I save source of the email and remove extra CRLF after every MIME attachment start boundary  
output (and all others) and display modified version in email client everything works just fine.

Updated

6 years ago
Keywords: qawanted

Comment 1

5 years ago
Your Bugzilla server is Windows? And did you customize/edit email templates? This would probably explain it.
(Reporter)

Comment 2

5 years ago
(In reply to Frédéric Buclin from comment #1)
> Your Bugzilla server is Windows? And did you customize/edit email templates?
> This would probably explain it.

Recently I have updated Bugzilla to version 4.2.2.
Running @ :
- Debian 2.6.26-27 
- perl 5, version 14, subversion 2 (v5.14.2) built for i486-linux-gnu-thread-multi-64int (with 53 registered patches, see perl -V for more detail)
- Apache/2.2.21 (Debian)

No templates were modified prior to bug occurred - after that, there is a chance I've may tried to solve it on my own ... but ... when upgrading to 4.2.2. I am almost certain I replaced all my files with one from original package.

Bug persists ... 
If you need any additional info like file list in my installation (with md5sum?) or any other info that may mater - just say :).

Comment 3

5 years ago
I run into the same issue at version 4.2.3.  I am sure I haven't changed any email settings and email templates.

The empty email body was caused by the email with the wrong MIME encoding format. I think

You can open the  attachment 604862 [details] with thunderbird email client. Then view the email source. You would find that all email content are there, But it can't be decoded correctly by the email client. 

I am not familiar with MIME encoding. But from the source of the email. I can see the plain text and MIME encoding text were mixed in the email body section. It's not the consistent MIME encoding for the whole email body.

I guess the mixture of plain text and MIME encoding confused the email client. Then only blank was displayed

Comment 4

5 years ago
I have figured out the root cause.
I said I haven't changed any email template in pre comment. But I was using localization bugzilla version. Actually the blank email body was caused by the email template  ".../template/$lang/default/email/bugmail-header.txt.tmpl".
Because there is a definition for the line break of email header. It must be "\r\n" instead of the linux "\n". When the email header template was localized, the line break was changed to "\n". It confused the email client and empty email body was displayed.

After I changed the line break for email header in the template from "\n" to "\r\n", The email body was displayed as normal.

Hope this help for you!
(Reporter)

Comment 5

5 years ago
(In reply to climby from comment #4)
> I have figured out the root cause.
> I said I haven't changed any email template in pre comment. But I was using
> localization bugzilla version. Actually the blank email body was caused by
> the email template 
> ".../template/$lang/default/email/bugmail-header.txt.tmpl".
> Because there is a definition for the line break of email header. It must be
> "\r\n" instead of the linux "\n". When the email header template was
> localized, the line break was changed to "\n". It confused the email client
> and empty email body was displayed.

I am a bit confused. I don't use localization (my bugzilla displays in english), also "Language used in email" is set to "Site Default (en)". In file you are mentioning ("template/en/default/email/bugmail-header.txt.tmpl") there is no line containing "\n" or "\r\n"

> 
> After I changed the line break for email header in the template from "\n" to
> "\r\n", The email body was displayed as normal.
> 
> Hope this help for you!

What am I missing?
(Reporter)

Comment 6

5 years ago
I did full system reinstall, did not copy any of files from previous instalation and problem is gone.
Thanks for help.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → WONTFIX

Updated

5 years ago
Keywords: qawanted
Resolution: WONTFIX → WORKSFORME
You need to log in before you can comment on or make changes to this bug.