The user is redirected from the homepage at livingsocial.com

RESOLVED INVALID

Status

()

Firefox for Android
General
RESOLVED INVALID
6 years ago
2 years ago

People

(Reporter: AdrianT, Unassigned)

Tracking

13 Branch
ARM
Android
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

6 years ago
Created attachment 604904 [details]
Nightly-Android Browser comparison

Fennec/13.0a1 2012-03-10
Device: HTC Desire (Android 2.2.2)

Steps to reproduce:
1. Open Nightly.
2. Go to livingsocial.com.
3. Skip the newsletter registration.
4. Wait for the main content to load.

Expected results:
The list of offers is displayed for the selected town.

Actual results:
The user is redirected to the first offer without the possibility of changing location or viewing other products.

Notes:
The issue is not reproducible on the Android Browser. The same issue is seen for Opera Mobile.

The header from web-sniffer.net is:
HTTP/1.1 302 FOUND
Server: nginx
Content-Type: text/html; charset=utf-8
Connection: close
Set-Cookie: preferred_city=;domain=livingsocial.com;path=/;expires=Thu,01-Jan-1970 00:00:00 GMT
Set-Cookie: preferred_city_id;domain=.livingsocial.com;path=/;expires=Thu, 12-Mar-2015 10:49:28 GMT
Set-Cookie: root_visit=1;domain=livingsocial.com;path=/;expires=Mon,12-Mar-2012 10:49:58 GMT
Set-Cookie: _fs=;domain=livingsocial.com;path=/;expires=Thu,01-Jan-1970 00:00:00 GMT
Set-Cookie: _session=ea5586b5a903c28728d8b4b1f8d8e7c8;path=/;HttpOnly
P3P: CP="NOI DSP COR NID ADMa OPTa OUR NOR"
Cache-Control: no-cache
Sounds like a site issue to me.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.