Add support for device orientation and device motion on gonk

RESOLVED DUPLICATE of bug 735330

Status

()

Core
DOM: Device Interfaces
RESOLVED DUPLICATE of bug 735330
6 years ago
6 years ago

People

(Reporter: mwu, Assigned: mwu)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Assignee)

Description

6 years ago
Created attachment 604931 [details] [diff] [review]
Device orientation and motion support on gonk
Attachment #604931 - Flags: review?(jones.chris.g)
Comment on attachment 604931 [details] [diff] [review]
Device orientation and motion support on gonk

"b2g" is a product, not a platform.  "Gonk" is a platform.

But, this should instead be a "hal" backend for orientation/motion.  This code works on any platform with a hal sensor impl.  Only enabling it for gonk now is fine.

Code mostly looks ok, didn't review closely.  Please re-request with reorg changes.
Attachment #604931 - Flags: review?(jones.chris.g) → review-
dougt has interest in this code.
(Assignee)

Comment 3

6 years ago
dougt got this.
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 735330
You need to log in before you can comment on or make changes to this bug.