Last Comment Bug 734903 - Undefined reference to XRE_GetProcessType in nsMediaCacheRemover.cpp on mingw
: Undefined reference to XRE_GetProcessType in nsMediaCacheRemover.cpp on mingw
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: XPCOM (show other bugs)
: Trunk
: x86 Windows 7
: -- normal (vote)
: mozilla14
Assigned To: Jacek Caban
:
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-03-12 09:29 PDT by Jacek Caban
Modified: 2012-03-15 08:00 PDT (History)
3 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
fix v1.0 (628 bytes, patch)
2012-03-12 09:29 PDT, Jacek Caban
benjamin: review+
Details | Diff | Splinter Review

Description Jacek Caban 2012-03-12 09:29:40 PDT
Created attachment 604983 [details] [diff] [review]
fix v1.0

It's because xpcom/io is missing |LIBXUL_LIBRARY  = 1|. Without it, XRE_GetProcessType (used after landing bug 612246) is declared as dllimport, while we shouldn't be importing it (it's compiled into xul.dll together with nsMediaCacheRemover.cpp).

The attached patch passes on try:
https://tbpl.mozilla.org/?tree=Try&rev=5b66e667452f
Comment 1 Chris Pearce (:cpearce) 2012-03-12 10:35:18 PDT
Comment on attachment 604983 [details] [diff] [review]
fix v1.0

Review of attachment 604983 [details] [diff] [review]:
-----------------------------------------------------------------

Looks fine to me, but I'm not an XPCOM peer, so we'd better ask one of them for review instead.
Comment 2 Jacek Caban 2012-03-14 07:10:30 PDT
Thanks for reviews.

https://hg.mozilla.org/integration/mozilla-inbound/rev/cec986f756d4
Comment 3 Marco Bonardo [::mak] (Away 6-20 Aug) 2012-03-15 08:00:18 PDT
https://hg.mozilla.org/mozilla-central/rev/cec986f756d4

Note You need to log in before you can comment on or make changes to this bug.