Last Comment Bug 734975 - Remove the XULRunner installer on Mac and switch the package to a .tar.bz2
: Remove the XULRunner installer on Mac and switch the package to a .tar.bz2
Status: RESOLVED FIXED
: dev-doc-needed
Product: Core
Classification: Components
Component: Build Config (show other bugs)
: unspecified
: x86 Mac OS X
: -- normal (vote)
: mozilla14
Assigned To: Benjamin Smedberg [:bsmedberg]
:
:
Mentors:
Depends on: 743560 744098 744428 747005
Blocks:
  Show dependency treegraph
 
Reported: 2012-03-12 12:13 PDT by Benjamin Smedberg [:bsmedberg]
Modified: 2012-04-19 08:18 PDT (History)
5 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Remove the installer, rev. 1 (2.56 KB, patch)
2012-03-12 12:14 PDT, Benjamin Smedberg [:bsmedberg]
no flags Details | Diff | Splinter Review
Remove the installer, rev. 1.1 (8.52 KB, patch)
2012-03-14 08:13 PDT, Benjamin Smedberg [:bsmedberg]
dtownsend: review+
Details | Diff | Splinter Review
bustage fix WIP (6.02 KB, patch)
2012-03-30 17:10 PDT, Dave Townsend [:mossop]
no flags Details | Diff | Splinter Review
bustage fix (6.02 KB, patch)
2012-04-04 16:47 PDT, Dave Townsend [:mossop]
benjamin: review+
Details | Diff | Splinter Review

Description Benjamin Smedberg [:bsmedberg] 2012-03-12 12:13:07 PDT
Currently we package a XULRunner installer on mac which will install XULRunner to /Library/Frameworks/XUL.framework. This wasn't a good idea to begin with and we removed support for even searching in system locations a while back. We want application authors to package XULRunner in their individual application bundles. To that end, I have removed the installer generation code and am just going "back" to packaging a .tar.bz2 file.
Comment 1 Benjamin Smedberg [:bsmedberg] 2012-03-12 12:14:56 PDT
Created attachment 605046 [details] [diff] [review]
Remove the installer, rev. 1
Comment 2 Dave Townsend [:mossop] 2012-03-13 16:24:35 PDT
Comment on attachment 605046 [details] [diff] [review]
Remove the installer, rev. 1

Review of attachment 605046 [details] [diff] [review]:
-----------------------------------------------------------------

This doesn't include the removals for xulrunner/installer/mac. Is that a mistake or intentional?

The readme looks good to me, I think as long as it links to the website then that should give everyone all the info they might want. Do we want to mention the license or is a LICENSE file already included somewhere?
Comment 3 Benjamin Smedberg [:bsmedberg] 2012-03-14 08:13:46 PDT
Created attachment 605757 [details] [diff] [review]
Remove the installer, rev. 1.1

There is a separate LICENSE file. Not including the xulrunner/installer/mac removal in the patch was accidental. `hg rm` and `rm` aren't identical ;-)
Comment 4 Ed Morley [:emorley] 2012-03-24 14:05:52 PDT
https://hg.mozilla.org/mozilla-central/rev/6fd5e0d9d94b
Comment 5 Benjamin Smedberg [:bsmedberg] 2012-03-26 12:38:54 PDT
This broke the universal build due to flight.mk referencing xulrunner/installer/mac: I'll work on fixing that tomorrow.
Comment 6 Dave Townsend [:mossop] 2012-03-30 17:10:41 PDT
Created attachment 611093 [details] [diff] [review]
bustage fix WIP

This at least makes the build and package steps complete in universal builds. I haven't done any testing in non-UB or comparisons to what was generated before and after yet though.
Comment 7 Dave Townsend [:mossop] 2012-04-04 16:47:01 PDT
Created attachment 612399 [details] [diff] [review]
bustage fix

I've run builds locally in both non-universal and universal and all succeed and package both XULRunner and the SDK ok. I didn't go so far as comparing the exact files included because of one complication, it turns out that we now omnijar XULRunner where we didn't when doing a pkg. A brief check shows all relevant files are present and I can run an application with the generated framework.

There were a bunch of problems with packaging here, mostly stemming from the fact that all of the support for packaging a bundle is ifdeffed behind a check for the package format being DMG. I suspect it doesn't need to be ifdeffed behind anything but to minimise the potential for breakage elsewhere I hid it behind toolkit=cocoa here.

I also made a slight change to where we tar file from so the tarball contains the XUL.framework directory directly (rather than xulrunner/XUL.framework).
Comment 8 Benjamin Smedberg [:bsmedberg] 2012-04-05 09:44:39 PDT
Comment on attachment 612399 [details] [diff] [review]
bustage fix

Yeah, I got halfway through writing the same patch and got stuck! thanks for finishing this.
Comment 9 Dave Townsend [:mossop] 2012-04-05 10:36:26 PDT
Landed on inbound: https://hg.mozilla.org/integration/mozilla-inbound/rev/d36aeec1abe1
Comment 10 Matt Brubeck (:mbrubeck) 2012-04-06 11:31:23 PDT
https://hg.mozilla.org/mozilla-central/rev/d36aeec1abe1
Comment 11 Alex Vincent [:WeirdAl] 2012-04-18 18:51:16 PDT
This is a pretty significant change for XULRunner app developers.  The XULRunner docs could use some tender loving care, anyway...

Note You need to log in before you can comment on or make changes to this bug.