crash java Caused by: java.lang.NullPointerException at org.mozilla.gecko.GeckoNetworkManager.getNetworkType(GeckoNetworkManager.java:225)

RESOLVED DUPLICATE of bug 746938

Status

()

Firefox for Android
General
--
critical
RESOLVED DUPLICATE of bug 746938
6 years ago
6 years ago

People

(Reporter: nhirata, Unassigned)

Tracking

({crash})

12 Branch
ARM
Android
crash
Points:
---

Firefox Tracking Flags

(blocking-fennec1.0 -)

Details

(Whiteboard: [native-crash], crash signature)

This bug was filed from the Socorro interface and is 
report bp-6ee97a04-d3bf-4d21-aa7a-5a5b52120311 .
============================================================= 
ava.lang.RuntimeException: Unable to resume activity {org.mozilla.fennec_aurora/org.mozilla.fennec_aurora.App}: java.lang.NullPointerException
	at android.app.ActivityThread.performResumeActivity(ActivityThread.java:2120)
	at android.app.ActivityThread.handleResumeActivity(ActivityThread.java:2135)
	at android.app.ActivityThread$H.handleMessage(ActivityThread.java:957)
	at android.os.Handler.dispatchMessage(Handler.java:99)
	at android.os.Looper.loop(Looper.java:130)
	at org.mozilla.gecko.GeckoApp$32.run(GeckoApp.java:1777)
	at android.os.Handler.handleCallback(Handler.java:587)
	at android.os.Handler.dispatchMessage(Handler.java:92)
	at android.os.Looper.loop(Looper.java:130)
	at android.app.ActivityThread.main(ActivityThread.java:3683)
	at java.lang.reflect.Method.invokeNative(Native Method)
	at java.lang.reflect.Method.invoke(Method.java:507)
	at com.android.internal.os.ZygoteInit$MethodAndArgsCaller.run(ZygoteInit.java:861)
	at com.android.internal.os.ZygoteInit.main(ZygoteInit.java:619)
	at dalvik.system.NativeStart.main(Native Method)
Caused by: java.lang.NullPointerException
	at org.mozilla.gecko.GeckoNetworkManager.getNetworkType(GeckoNetworkManager.java:225)
	at org.mozilla.gecko.GeckoNetworkManager.updateNetworkType(GeckoNetworkManager.java:183)
	at org.mozilla.gecko.GeckoNetworkManager.start(GeckoNetworkManager.java:158)
	at org.mozilla.gecko.GeckoApp.onResume(GeckoApp.java:2087)
	at android.app.Instrumentation.callActivityOnResume(Instrumentation.java:1150)
	at android.app.Activity.performResume(Activity.java:3838)
	at android.app.ActivityThread.performResumeActivity(ActivityThread.java:2110)
	... 14 more

Earliest Build: 20120215042007

More Reports: 
https://crash-stats.mozilla.com/report/list?query_search=signature&query_type=contains&reason_type=contains&range_value=4&range_unit=weeks&hang_type=any&process_type=any&signature=java.lang.RuntimeException%3A%20Unable%20to%20resume%20activity%20{org.mozilla.fennec_aurora%2Forg.mozilla.fennec_aurora.App}%3A%20java.lang.NullPointerException%3A%20at%20android.app.ActivityThread.performResumeActivity%28ActivityThread.java%29

Updated

6 years ago
Hardware: All → ARM
blocking-fennec1.0: --- → -

Updated

6 years ago
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 746938
You need to log in before you can comment on or make changes to this bug.