Last Comment Bug 735109 - unregister message listeners on shutdown in Webapps.jsm
: unregister message listeners on shutdown in Webapps.jsm
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: DOM (show other bugs)
: Other Branch
: All All
: -- normal (vote)
: mozilla13
Assigned To: [:fabrice] Fabrice Desré
:
Mentors:
: 725533 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-03-12 16:50 PDT by [:fabrice] Fabrice Desré
Modified: 2012-03-13 15:06 PDT (History)
3 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
patch (1.41 KB, patch)
2012-03-12 16:50 PDT, [:fabrice] Fabrice Desré
felipc: review+
Details | Diff | Splinter Review

Description [:fabrice] Fabrice Desré 2012-03-12 16:50:36 PDT
Created attachment 605221 [details] [diff] [review]
patch

We leak without that.
Comment 1 :Felipe Gomes (needinfo me!) 2012-03-12 17:20:06 PDT
Comment on attachment 605221 [details] [diff] [review]
patch

Very close, I tested with this patch and we also need to clear ppmm to null on shutdown, then the leak is gone!
Comment 2 [:fabrice] Fabrice Desré 2012-03-12 17:35:09 PDT
https://hg.mozilla.org/integration/mozilla-inbound/rev/329878c0813d
Comment 3 Marco Bonardo [::mak] (Away 6-20 Aug) 2012-03-13 05:45:32 PDT
https://hg.mozilla.org/mozilla-central/rev/329878c0813d
Comment 4 :Felipe Gomes (needinfo me!) 2012-03-13 15:06:16 PDT
*** Bug 725533 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.