Closed Bug 735112 Opened 9 years ago Closed 8 years ago

java.util.ConcurrentModificationException at java.util.HashMap$HashIterator.nextEntry(HashMap.java) at org.mozilla.gecko.GeckoApp.hidePlugins(GeckoApp.java)

Categories

(Firefox for Android :: General, defect)

ARM
Android
defect
Not set
critical

Tracking

()

RESOLVED FIXED
Firefox 17
Tracking Status
blocking-fennec1.0 --- -

People

(Reporter: nhirata, Assigned: snorp)

Details

(Keywords: crash, Whiteboard: [native-crash])

Crash Data

Attachments

(2 files)

This bug was filed from the Socorro interface and is 
report bp-965f1828-cba4-49bc-bae3-473102120310 .
============================================================= 
java.util.ConcurrentModificationException
	at java.util.HashMap$HashIterator.nextEntry(HashMap.java:792)
	at java.util.HashMap$ValueIterator.next(HashMap.java:824)
	at org.mozilla.gecko.GeckoApp.hidePlugins(GeckoApp.java:1549)
	at org.mozilla.gecko.GeckoApp$4.run(GeckoApp.java:755)
	at android.os.Handler.handleCallback(Handler.java:605)
	at android.os.Handler.dispatchMessage(Handler.java:92)
	at android.os.Looper.loop(Looper.java:137)
	at org.mozilla.gecko.GeckoApp$32.run(GeckoApp.java:1777)
	at android.os.Handler.handleCallback(Handler.java:605)
	at android.os.Handler.dispatchMessage(Handler.java:92)
	at android.os.Looper.loop(Looper.java:137)
	at android.app.ActivityThread.main(ActivityThread.java:4424)
	at java.lang.reflect.Method.invokeNative(Native Method)
	at java.lang.reflect.Method.invoke(Method.java:511)
	at com.android.internal.os.ZygoteInit$MethodAndArgsCaller.run(ZygoteInit.java:787)
	at com.android.internal.os.ZygoteInit.main(ZygoteInit.java:554)
	at dalvik.system.NativeStart.main(Native Method)

https://crash-stats.mozilla.com/report/list?version=FennecAndroid%3A12.0a2&query_search=signature&query_type=contains&reason_type=contains&date=2012-03-12&range_value=28&range_unit=days&hang_type=any&process_type=any&signature=java.util.ConcurrentModificationException%3A%20at%20java.util.HashMap%24HashIterator.nextEntry%28HashMap.java%29

Earliest report : 20120223042013
Hardware: All → ARM
blocking-fennec1.0: --- → +
blocking-fennec1.0: + → -
I was getting this crash with the testcase from bug 727512, open the tab list popup, closing the parent tab that is endlessly opening all the windows.
Attached file testcase
The crash in comment 1 might be a little bit different.

This testcase gives the same crash as what is mentioned in comment 0:
https://crash-stats.mozilla.com/report/index/bp-62833bfa-8d32-460b-932f-ea8382120525
Reproduced this on the Galaxy Nexus.

Steps to reproduce:
- Make sure you have Plugins enabled in the settings
- Visit testcase, tap on the button
- When popups are blocked after the second popup, let it allow popups for this site.

After a few times opening/closing windows, it should crash Fennec.
This was relatively easy to find now that bug 731288 is fixed, btw.

Asking for blocking, since this crash bug now has a testcase.
blocking-fennec1.0: - → ?
Keywords: testcase
The opened window code consists of this:
<embed type="application/x-shockwave-flash">
<embed type="application/x-shockwave-flash">
<script>
setTimeout(function() {document.write('test');}, 5000);
</script>
Version: Firefox 12 → Trunk
Assignee: nobody → snorp
blocking-fennec1.0: ? → soft
blocking-fennec1.0: soft → -
Keywords: qawanted
Why does this bug have gotten 'qawanted' keyword. What does QA need to do here?
I attached a testcase that reproduces the crash. Or are you not able to reproduce the crash?
qawanted is to retest, assertion being that this may be fixed already
Ok, current trunk build doesn't seem to crash anymore with the testcase on the Galaxy Nexus and the Galaxy SII. Marking WFM.
Status: NEW → RESOLVED
Closed: 9 years ago
Keywords: qawanted
Resolution: --- → WORKSFORME
There's one crash in 14.0b6 with the stack in comment 0: bp-bd9703c1-37f2-4043-90fc-0b7702120608.
Status: RESOLVED → REOPENED
Keywords: testcase
Resolution: WORKSFORME → ---
Summary: crash [@ java.util.ConcurrentModificationException at java.util.HashMap$HashIterator.nextEntry(HashMap.java:792)] → java.util.ConcurrentModificationException at java.util.HashMap$HashIterator.nextEntry(HashMap.java) at org.mozilla.gecko.GeckoApp.hidePlugins(GeckoApp.java)
Attachment #633538 - Flags: review?(blassey.bugs) → review+
It still happens. Can someone land the patch?
https://hg.mozilla.org/mozilla-central/rev/36f21854b627
Status: REOPENED → RESOLVED
Closed: 9 years ago8 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 17
You need to log in before you can comment on or make changes to this bug.