eBay uses wrong charset (UTF-16)

VERIFIED FIXED

Status

Tech Evangelism Graveyard
English US
P1
normal
VERIFIED FIXED
17 years ago
3 years ago

People

(Reporter: Daniel J. Peng, Assigned: Katsuhiko Momoi)

Tracking

Details

(URL)

(Reporter)

Description

17 years ago
All of eBay's bid histories have the tag <META http-equiv="Content-Type"
content="text/html; charset=UTF-16">, but the documents don't seem to be in
UTF-16.  If you load it, you get a page of trash.  If you go to View->Character
Encoding->Western (ISO-8859-1), it renders fine.

Comment 1

17 years ago
Marking NEW.
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 2

17 years ago
Reassigning evangelism bugs to bclary@netscape.com.
Assignee: evangelism → bclary

Updated

17 years ago
Priority: -- → P1

Comment 3

17 years ago
Assigning to Kat as he's expert at char sets
Assignee: bclary → momoi
(Assignee)

Comment 4

17 years ago
Ebay has changed the script such that charset line is now 
commented out. With 6/15/2001 Win32 build. This bug is
now Worksforme.
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → WORKSFORME

Comment 5

17 years ago
reopening to resolve correctly.
Status: RESOLVED → REOPENED
Resolution: WORKSFORME → ---

Comment 6

17 years ago
resolving fixed as ebay have changed their code.
Status: REOPENED → RESOLVED
Last Resolved: 17 years ago17 years ago
Resolution: --- → FIXED
(Assignee)

Comment 7

17 years ago
I believe I resolved it correctly the first time. 
Neither I nor anyone else made a code change to
bring about the current status. Though the descrption
for Worksforme leave a bit to be desired, that is
the closest to what happened to this bug. But I 
won't expend more energy on this. 

Comment 8

17 years ago
All Evangelism Bugs are now in the Product Tech Evangelism. See bug 86997 for
details.
Component: Evangelism → US English
Product: Browser → Tech Evangelism
Version: other → unspecified

Comment 9

17 years ago
Kat, in general if the site fixes their content so that it works then an
Evangelism bug is fixed. If the site has a problem reported but it can not be
reproduced then it is works for me. either way:

<!--A http-equiv="Content-Type" content="text/html; charset=UTF-1-->
<meta HTTP-EQUIV="Content-Type" CONTENT="text/html; charset=ISO8859-1">

verified
Status: RESOLVED → VERIFIED
Product: Tech Evangelism → Tech Evangelism Graveyard
You need to log in before you can comment on or make changes to this bug.