Add-On Builder hides amp; when typed into editor

RESOLVED WORKSFORME

Status

addons.mozilla.org Graveyard
Add-on Builder
RESOLVED WORKSFORME
6 years ago
3 years ago

People

(Reporter: dermot, Unassigned)

Tracking

unspecified
Q2 2012

Details

(Reporter)

Description

6 years ago
User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:10.0.1) Gecko/20100101 Firefox/10.0.1
Build ID: 20120208060813

Steps to reproduce:

typed amp; into editor


Actual results:

The editor did not show the letters amp; but it behaved as if they were there, because if I edited a character to the right of amp;, it edited the wrong letter, and the length of the line is shown as 4 chars longer than it actually is.


Expected results:

The editor should treat amp; as literal text

Comment 1

6 years ago
Hm, this could explain why so many pages display the double "amp;" when you would expect the authors of the pages to know how to write the ampersand character in HTML code to make it show up identical in any browser. Would it be useful to check the HTML code for which editor is used when this behavior appears?
It looks like it's work for me. 

I do see the amp; (or & for the matter) being added to the text and it is there after save and reload

Please change the status if you still see it.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → WORKSFORME
Target Milestone: --- → Q2 2012
(Assignee)

Updated

3 years ago
Product: addons.mozilla.org → addons.mozilla.org Graveyard
You need to log in before you can comment on or make changes to this bug.