Closed Bug 735180 Opened 9 years ago Closed 9 years ago

Maple: support.mozilla.org - Page Menu pops-up when dragging down the page

Categories

(Firefox for Android Graveyard :: General, defect)

13 Branch
ARM
Android
defect
Not set
normal

Tracking

(Not tracked)

VERIFIED FIXED

People

(Reporter: csuciu, Assigned: kats)

References

Details

(Whiteboard: maple)

Attachments

(1 file)

Maple nightly 13.0a1 2012-03-12 (20120312155232)
Samsung Galaxy SII (Android 2.3.4)

Steps:
1. Load support.mozilla.org
2. Drag the page down. Do not tap on the page Menu button.

Expected:
The page Menu should not expand without tapping on the Menu button  

Actual:
The page Menu will expand outside the page, in the upper side, while dragging down the page.

Note
Unreproducible on Nexus S (Android 2.3.6).
Blocks: 729169
Assignee: nobody → bugmail.mozilla
Attached patch PatchSplinter Review
This regressed when I moved the display port calculations from JS to Java, because in Java we can have overscroll and so "negative" display port margins actually make sense.
Attachment #605400 - Flags: review?(chrislord.net)
Whiteboard: maple
Comment on attachment 605400 [details] [diff] [review]
Patch

Review of attachment 605400 [details] [diff] [review]:
-----------------------------------------------------------------

Looks good to me, some details clarified over IRC but I don't think this requires elaboration.
Attachment #605400 - Flags: review?(chrislord.net) → review+
https://hg.mozilla.org/projects/maple/rev/20a6f6aee48c
Status: NEW → RESOLVED
Closed: 9 years ago
Resolution: --- → FIXED
For future reference, the STR I used to reproduce the problem were:

1. load support.mozilla.org
2. pinch zoom in so that you can see the background around the page
3. lift one finger while leaving the second one down
4. pull the page down with the remaining finger, then pause and wait for a redraw

expected results: page draws properly
observed results: at this point the menu will get drawn into the overscroll area above the page
Verified fixed on:
Nightly 14.0a1 (2012-04-12) 20120412030726
Samsung Galaxy SII (Android 2.3.4)
Status: RESOLVED → VERIFIED
Product: Firefox for Android → Firefox for Android Graveyard
You need to log in before you can comment on or make changes to this bug.