Last Comment Bug 735194 - gfxDWriteFontList.cpp fails to compile on mingw
: gfxDWriteFontList.cpp fails to compile on mingw
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: Graphics (show other bugs)
: Trunk
: x86 Windows 7
: -- normal (vote)
: mozilla14
Assigned To: Jacek Caban
:
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-03-13 04:41 PDT by Jacek Caban
Modified: 2012-04-05 10:46 PDT (History)
3 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
fix v1.0 (8.24 KB, patch)
2012-03-13 04:41 PDT, Jacek Caban
bas: review+
Details | Diff | Splinter Review

Description Jacek Caban 2012-03-13 04:41:59 PDT
Created attachment 605343 [details] [diff] [review]
fix v1.0

It's mostly because mingw can't provide macros like __in as they would conflict with c++ standard includes. It's no-op anyways so it's safe to remove it. Also Interlocked* functions take long*, not usigned long*, as argument, so I've changed mRefCount's type. While I was at this I've fixed warnings (signed-unsigned compare, NULL instead of 0 for integer args and unused variables).
Comment 1 John Daggett (:jtd) 2012-03-16 21:25:13 PDT
Comment on attachment 605343 [details] [diff] [review]
fix v1.0

Sorry, I'm not really sure I understand how to review your changes.  Switching this review to bas, who may understand these issues better than I do.
Comment 2 Jacek Caban 2012-04-03 12:02:34 PDT
Bas, ping
Comment 3 Bas Schouten (:bas.schouten) 2012-04-03 14:01:37 PDT
Comment on attachment 605343 [details] [diff] [review]
fix v1.0

Review of attachment 605343 [details] [diff] [review]:
-----------------------------------------------------------------

Nothing objectionable here if it makes both mingw and MSVC happy.
Comment 4 Jacek Caban 2012-04-04 02:18:55 PDT
Thanks for the review.

https://hg.mozilla.org/integration/mozilla-inbound/rev/c52251654441
Comment 5 :Ehsan Akhgari (away Aug 1-5) 2012-04-05 10:46:02 PDT
https://hg.mozilla.org/mozilla-central/rev/c52251654441

Note You need to log in before you can comment on or make changes to this bug.