All users were logged out of Bugzilla on October 13th, 2018

Crash in nsCacheService::ProcessPendingRequests()

VERIFIED FIXED

Status

()

--
critical
VERIFIED FIXED
18 years ago
18 years ago

People

(Reporter: tever, Assigned: gordon)

Tracking

({crash})

Trunk
x86
Linux
crash
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [cache], URL)

(Reporter)

Description

18 years ago
Overview Description:  This is an intermittant crash that I am seeing when 
running through the i-bench tests.  I have seen it twice now (out of approx 12 
runs).  The crash happened fairly quickly within the first few i-bench test 
pages and after clearing the cache and restarting the tests.

Steps to Reproduce:
1.)  Run the ibench tests

Build Date & Platform Bug Found:
Linux rh6.0 build 2001032608

Additional Information:

Talkback report -

nsCacheService::ProcessPendingRequests() 
nsCacheService::DoomEntry_Locked() 
nsDiskCacheDevice::BindEntry() 
nsCacheService::EnsureEntryHasDevice() 
nsCacheService::GetTransportForEntry() 
EnsureTransportWithAccess() 
OpenOutputStream() 
nsHTTPChannel::CacheReceivedResponse() 
nsHTTPChannel::ProcessStatusCode() 
nsHTTPChannel::FinishedResponseHeaders() 
nsHTTPServerListener::FinishedResponseHeaders() 
nsHTTPServerListener::OnDataAvailable() 
nsOnDataAvailableEvent::HandleEvent() 
nsStreamObserverEvent::HandlePLEvent() 
PL_HandleEvent() 
PL_ProcessEventsBeforeID() 
processQueue() 
nsVoidArray::EnumerateForwards() 
nsAppShell::ProcessBeforeID() 
handle_gdk_event() 
libgdk-1.2.so.0 + 0x170fb (0x405340fb) 
libglib-1.2.so.0 + 0xfa86 (0x4055ea86) 
libglib-1.2.so.0 + 0x10041 (0x4055f041) 
libglib-1.2.so.0 + 0x101e1 (0x4055f1e1) 
libgtk-1.2.so.0 + 0x8b7a9 (0x4048b7a9) 
nsAppShell::Run() 
nsAppShellService::Run() 
main1() 
main()
(Reporter)

Comment 1

18 years ago
nominating nsbeta1
Keywords: crash, nsbeta1
QA Contact: gordon → tever
Summary: Crash in nsCacheService::ProcessPendingRequests() → Crash in nsCacheService::ProcessPendingRequests()
(Assignee)

Updated

18 years ago
Whiteboard: [cache]

Comment 2

18 years ago
This may be a duplicate of bug 73780. The special thing here is an additional
nsCacheService::ProcessPendingEvents() frame on top of the stack.
(Assignee)

Comment 3

18 years ago
I believe this has been fixed with the landing of the DISKCACHE1_BRANCH.  Please
verify with a build from 2001/04/04 or later and reopen if it occurs again.

Marking FIXED.

Thanks.
Status: NEW → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → FIXED
(Reporter)

Comment 4

18 years ago
actually I never saw this again after those first two times

Verified
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.