Image resize using css div width causes choppy scrolling

RESOLVED INVALID

Status

()

Firefox
Untriaged
RESOLVED INVALID
6 years ago
4 years ago

People

(Reporter: Andy Bajka, Unassigned)

Tracking

10 Branch
x86
Mac OS X
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

6 years ago
User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.6; rv:10.0.2) Gecko/20100101 Firefox/10.0.2
Build ID: 20120215223356

Steps to reproduce:

This problem only occurs using my Mac running 10.6.8 with Firefox. All other browsers and operating systems work fine.

I have 20 large images that are displayed here:

http://www.bajka.com/test.html

I'm using css to control the width of the images so that each image is scaled down to 1200px. 


Actual results:

If you scroll using the slider on the right with your mouse you will see how choppy the scrolling is. If I remove the css and allow the images to be full size the scrolling is very smooth.


Expected results:

Scrolling should be smooth.
(Reporter)

Comment 1

6 years ago
I just installed Firefox/11.0 and the choppy scrolling is not as bad as it was in 10.0.2. Firefox is not as smooth as Chrome so there is still room for improvement, but it's great to see the improvement with version 11.0.
(Reporter)

Comment 2

6 years ago
The scrolling is just as choppy in version 11 as it was in version 10.
(Reporter)

Comment 3

6 years ago
The scrolling is just as choppy in version 12 as it was in version 11.
(Reporter)

Comment 4

6 years ago
The scrolling is just as choppy in version 13 as it was in version 12.
(Reporter)

Comment 5

6 years ago
I've since upgraded to OS X 10.8.1 and do not experience this issue any more. Please close bug as invalid.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.