Last Comment Bug 735335 - Participant list of IRC channels isn't finished
: Participant list of IRC channels isn't finished
Status: RESOLVED FIXED
:
Product: Thunderbird
Classification: Client Software
Component: Instant Messaging (show other bugs)
: Trunk
: All All
: -- normal (vote)
: Thunderbird 14.0
Assigned To: Florian Quèze [:florian] [:flo]
:
Mentors:
: 735999 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-03-13 11:09 PDT by Florian Quèze [:florian] [:flo]
Modified: 2012-04-02 04:10 PDT (History)
2 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
fixed


Attachments
Patch (5.71 KB, patch)
2012-03-15 04:50 PDT, Florian Quèze [:florian] [:flo]
bwinton: review+
Details | Diff | Review
As checked in (4.65 KB, patch)
2012-03-28 02:44 PDT, Florian Quèze [:florian] [:flo]
mozilla: approval‑comm‑aurora+
Details | Diff | Review

Description Florian Quèze [:florian] [:flo] 2012-03-13 11:09:54 PDT
- The tooltips (supposed to display whois results) don't work:
Error: document.getBindingParent(elt) is null
Source File: chrome://messenger/content/chat/imbuddytooltip.xml
Line: 398

- double clicking on a nick to start a private conversation doesn't work:
Error: onNickClick is not defined
Source File: chrome://messenger/content/messenger.xul
Line: 1

- pressing enter to start a private conversation with the selected nick doesn't work:
Error: onNicklistKeyPress is not defined
Source File: chrome://messenger/content/messenger.xul
Line: 1
Comment 1 Florian Quèze [:florian] [:flo] 2012-03-15 03:05:32 PDT
*** Bug 735999 has been marked as a duplicate of this bug. ***
Comment 2 Florian Quèze [:florian] [:flo] 2012-03-15 04:50:46 PDT
Created attachment 606165 [details] [diff] [review]
Patch
Comment 3 Blake Winton (:bwinton) (:☕️) (PTO 'til London. Find me there for quick answers!) 2012-03-27 12:22:01 PDT
Comment on attachment 606165 [details] [diff] [review]
Patch

>+++ b/mail/components/im/content/chat-messenger-overlay.js
>@@ -430,16 +430,44 @@ var chatHandler = {
>+  onNicklistKeyPress: function(aEvent) {
>+    if (aEvent.keyCode != aEvent.DOM_VK_RETURN &&
>+        aEvent.keyCode != aEvent.DOM_VK_ENTER)
>+      return;
>+
>+    let listbox = aEvent.originalTarget;
>+    if (listbox.selectedCount == 0)
>+      return;
>+
>+    let conv = document.getElementById("contactlistbox").selectedItem.conv;
>+    for (let i = 0; i < listbox.selectedCount; ++i) {
>+      let nick = listbox.getSelectedItem(i).chatBuddy.name;
>+      let name = conv.target.getNormalizedChatBuddyName(nick);
>+      conv.account.createConversation(name);
>+    }
>+  },
>+

Huh.  I think I would want hitting enter to open a single group chat with all the selected nicks, not a new chat with each nick…

On the other hand, I can't seem to select more than one nick in the nicklist, so perhaps it's not a problem in practice.

> - The tooltips (supposed to display whois results) don't work:

It works!  Woo!  ;)

> - double clicking on a nick to start a private conversation doesn't work:
> Error: onNickClick is not defined
> Source File: chrome://messenger/content/messenger.xul
> Line: 1
>
> - pressing enter to start a private conversation with the selected nick doesn't work:
> Error: onNicklistKeyPress is not defined
> Source File: chrome://messenger/content/messenger.xul
> Line: 1

These still fail (for twitter) with:
JavaScript error: , line 0: uncaught exception: [Exception... "'Method not implemented' when calling method: [prplIAccount::createConversation]"  nsresult: "0x80004001 (NS_ERROR_NOT_IMPLEMENTED)"  location: "JS frame :: file:///Volumes/SSD/Programming/thunderbird/objdir-comm-central-default/mozilla/dist/DailyDebug.app/Contents/MacOS/components/imAccounts.js :: <TOP_LEVEL> :: line 650"  data: no]

I think we should probably wrap the calls to "conv.account.createConversation(name);" in onNickClick and onNicklistKeyPress with a try/catch.

r=me with that fixed.  ;)

Thanks,
Blake.
Comment 4 Florian Quèze [:florian] [:flo] 2012-03-28 02:44:01 PDT
Created attachment 610052 [details] [diff] [review]
As checked in
Comment 5 Florian Quèze [:florian] [:flo] 2012-03-28 02:44:34 PDT
http://hg.mozilla.org/comm-central/rev/0ee50ffb3901
Comment 6 Florian Quèze [:florian] [:flo] 2012-03-30 05:53:15 PDT
Comment on attachment 610052 [details] [diff] [review]
As checked in

[Approval Request Comment]
User impact if declined: the list of channel participants is currently quite broken on aurora.
Comment 7 Florian Quèze [:florian] [:flo] 2012-04-02 04:10:15 PDT
http://hg.mozilla.org/releases/comm-aurora/rev/8ab141032937

Note You need to log in before you can comment on or make changes to this bug.