Last Comment Bug 735339 - The 'Get mail' drop down shouldn't list IM accounts
: The 'Get mail' drop down shouldn't list IM accounts
Status: RESOLVED FIXED
:
Product: Thunderbird
Classification: Client Software
Component: Instant Messaging (show other bugs)
: Trunk
: All All
: -- normal (vote)
: Thunderbird 14.0
Assigned To: Florian Quèze [:florian] [:flo]
:
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-03-13 11:14 PDT by Florian Quèze [:florian] [:flo]
Modified: 2012-04-02 04:09 PDT (History)
2 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
fixed


Attachments
Patch (5.20 KB, patch)
2012-03-14 09:15 PDT, Florian Quèze [:florian] [:flo]
mozilla: review+
mozilla: approval‑comm‑aurora+
Details | Diff | Splinter Review

Description Florian Quèze [:florian] [:flo] 2012-03-13 11:14:23 PDT
... as it's not possible to get new emails from an IM account.
Comment 1 Florian Quèze [:florian] [:flo] 2012-03-14 09:15:41 PDT
Created attachment 605791 [details] [diff] [review]
Patch

This patch will disable the "Get mail" menu/button/command if there's only IM accounts, in addition to hiding the IM accounts from the "Get Mail" popup menu, the "File -> Get New Messages for" menu and the "Go -> Folder" menu.
Comment 2 David :Bienvenu 2012-03-14 17:13:11 PDT
My chat accounts aren't showing up in go folders, or the get new mail dropdown, even w/o this patch. Why would that be? Or why would they show up for other people? Did the account stuff change since I created them in this profile?
Comment 3 Florian Quèze [:florian] [:flo] 2012-03-15 04:03:39 PDT
(In reply to David :Bienvenu from comment #2)
> My chat accounts aren't showing up in go folders, or the get new mail
> dropdown, even w/o this patch. Why would that be?

Maybe you are seeing bug 736035? If so, if you have any idea of the steps to reproduce, please comment in that bug.
Comment 4 David :Bienvenu 2012-03-15 13:46:32 PDT
Comment on attachment 605791 [details] [diff] [review]
Patch

can you use let instead of var for the new function IsGetNewMessagesEnabled()?
Comment 5 Florian Quèze [:florian] [:flo] 2012-03-23 04:15:45 PDT
http://hg.mozilla.org/comm-central/rev/f4b337e10b51
Comment 6 Florian Quèze [:florian] [:flo] 2012-03-30 05:54:58 PDT
Comment on attachment 605791 [details] [diff] [review]
Patch

[Approval Request Comment]
User impact if declined: quite visible brokenness in the mail UI if IM accounts exist.
Comment 7 Florian Quèze [:florian] [:flo] 2012-04-02 04:09:56 PDT
http://hg.mozilla.org/releases/comm-aurora/rev/a32b1a8e83a1

Note You need to log in before you can comment on or make changes to this bug.