Hang during login to Addon Collector

RESOLVED WONTFIX

Status

RESOLVED WONTFIX
7 years ago
3 years ago

People

(Reporter: bgoodr, Unassigned)

Tracking

Details

Attachments

(1 attachment)

(Reporter)

Description

7 years ago
Created attachment 605485 [details]
addon_collector_extension_hang.jpg

User Agent: Mozilla/5.0 (Windows NT 6.0; rv:10.0.2) Gecko/20100101 Firefox/10.0.2
Build ID: 20120215223356

Steps to reproduce:

This happens on two completely different networks (both at home and at work), both on 32-bit Windows Vista and on 32-bit Firefox running on 64-bit Debian Linux, so this is unlikely to be a network configuration issue. This has been happening for several days now.

Build identifier for this particular execution scenario: Mozilla/5.0 (Windows NT 6.0; rv:10.0.2) Gecko/20100101 Firefox/10.0.2

1. Invoke Firefox
2. Select Tools menu
3. Select Add-ons
4. Select Extensions on the left side 
5. Scroll down to Add-on Collector, and click on its Options button
6. Select the General Settings button
7. If there is a Log-out button, click on it so that the user is logged out.
8. Click on the Log-in button.



Actual results:

After clicking on the Log-in button, it hangs with a "Loading ..." image and a dotted circle that goes around and around infinitely. 



Expected results:

Logins should take no more than 5 seconds to complete, and not hang. See attached screenshot file (addon_collector_extension_hang.jpg).

Comment 1

7 years ago
The Collector is being retired at the end of the month.

http://blog.mozilla.com/addons/2012/03/07/add-on-collector-retiremen/
Status: UNCONFIRMED → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → WONTFIX
(Reporter)

Comment 2

7 years ago
The fact that it hangs with no user visible message is a defect. The hanging behavior gives the user no indication that the extension is being dropped/sunsetted/removed/deprecated.  Instead of hanging, it may be better to arrange it so that when the user clicks on the Login button, it browses to the http://blog.mozilla.com/addons/2012/03/07/add-on-collector-retiremen/ web page.  Alternatively, one could provide some other direct indication on that configuration page of the same (perhaps even removing the login or logout buttons), or similar.

Comment 3

7 years ago
Such a case could be made for such action, but this is not a widespread bug. Login works for me and I have not seen any similar bug reports.
(Assignee)

Updated

3 years ago
Product: addons.mozilla.org → addons.mozilla.org Graveyard
You need to log in before you can comment on or make changes to this bug.