Closed Bug 735494 Opened 10 years ago Closed 6 years ago

google sites lays divs all over each other (requires window.orientation support)

Categories

(Core :: General, defect)

ARM
Android
defect
Not set
normal

Tracking

()

RESOLVED FIXED

People

(Reporter: tchung, Unassigned)

References

()

Details

(Whiteboard: [website-compatibility][jquery][google])

Attachments

(3 files)

Attached image screenshot on Fennec
Visit URL on fennec Native.  Verify the site shows divs laying all over each other, while it lays out much nicer in Chrome or Stock android.  

No signs of webkit css. 

Also, Chrome or Stock Android doesn't seem to be serving up the Ads.  likely UA sniffing?

Repro:
1) launch fennec nightly 03-13-2013 build
2) visit URL
3) Verify layout issues

Expected:
- no layout issues like the screenshot

Actual:
- divs laying all over each other
Attached image screenshot on Chrome
Whiteboard: [website-compatibility]
No longer blocks: google-evangelism
Still busted.
Component: Evangelism → Mobile
Product: Firefox for Android → Tech Evangelism
Version: Trunk → unspecified
There is a menu meant to slide in/out from the right. If this menu starts out opened, it wil overlay the page in an ugly way on the small screen. This also happens in the stock browser if the menu is expanded (click the small triangle pointing left-wards). So the real bug is that the menu is expanded by default in Fx.
This is caused by missing window.orientation - site thinks we're in landscape mode and doesn't bother collapsing the menu. Is there a master bug for this?

This is the code, from job_min_view__en_gb.js:

return !(0!=window.orientation&&180!=window.orientation)
Not sure whom to ask about this - Jason, do you know? I haven't found any master bug so I'm moving this to core and attached a TC.
Component: Mobile → General
Product: Tech Evangelism → Core
Summary: google sites lays divs all over each other → google sites lays divs all over each other (requires window.orientation support)
920342 also fails because it assumes window.orientation.
Also orientationchange event support is detected through window.orientation in jQuery Mobile: https://github.com/jquery/jquery-mobile/blob/master/js/jquery.mobile.support.orientation.js
See Also: → 920342
Lawrence, this breaks some jQuery mobile stuff and we've found a couple of sites affected so far. It's a new (small) feature that I think we should implement in core. It consists of:

window.orientation - takes values like 0, 90, -90, 180 depending on how the device is held
orientationchange event that fires when the device is rotated

How can I nom or push this forward? Who should I nag?
Flags: needinfo?(lmandel)
Whiteboard: [website-compatibility] → [website-compatibility][jquery][google]
Please file a bug in Core::Layout for the request, add dependencies on this bug and bug 920342, and cc :jet.
Flags: needinfo?(lmandel)
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.